Welcome to WebmasterWorld Guest from

Forum Moderators: open

Message Too Old, No Replies

Confused by a problem when script doesn't work in IE6



11:54 pm on Feb 7, 2008 (gmt 0)

10+ Year Member


I have a script that loads Google Maps with Ajax. Everything works fine in Firefox 2 (Mac, Windows), Firefox 3 Beta (Mac), Safari 2, IE7, but script doesn't work in IE6. I get grey square instead of map there.

I strangest thing is I don't get any JS error.

I wonder how can I fix it, how can I find the error?

PS: You can see and example after you log in (login "test", password "thetest" ) here: <url removed>

Please click "Photo albums", then "Greece", then put mouse over "Options" under any photo and click "Map this photo".

If you use any browser except IE6, you'll se working map. In IE you'll see grey square.

[edited by: encyclo at 12:07 am (utc) on Feb. 8, 2008]
[edit reason] no URLs please [/edit]


1:58 am on Feb 8, 2008 (gmt 0)

10+ Year Member

Ok, moderator deleted my URL.

If anyone will be able to help me with this, please tell me and I'll PM you URL of the page. i will really appreciate any help.


11:29 am on Feb 8, 2008 (gmt 0)

WebmasterWorld Senior Member penders is a WebmasterWorld Top Contributor of All Time 5+ Year Member Top Contributors Of The Month

In IE you'll see grey square.

Only guessing... are you using transparent PNG images?


4:02 pm on Feb 8, 2008 (gmt 0)

10+ Year Member

Yes, but they are work in Google Maps on all other pages. I use 8bit PNGs which have no problems in IE I guess (as 24bit PNGs do).

Featured Threads

Hot Threads This Week

Hot Threads This Month