Welcome to WebmasterWorld Guest from 54.145.39.186

Forum Moderators: incrediBILL

Message Too Old, No Replies

Form not validating

What am I doing wrong?

     

mfmikeb

8:43 pm on Jul 6, 2004 (gmt 0)

10+ Year Member



This form is inside a table. When I try to validate on w3.org I get an error that says,
"end tag for element "FORM" which is not open </FORM>"
It is referring to the line where the /form is. But I have the form opened at the top.
What is wrong?

<form action=http://www.mysite.com>
<select name="worldwide" size="1" onChange="location.href=this.form.worldwide.options[this.form.worldwide.selectedIndex].value">
<option>Search Products
<OPTION VALUE="example">Example
<OPTION VALUE="example">Example
<OPTION VALUE="example">Example
<OPTION VALUE="example">Example
<OPTION VALUE="example">Example
</select>
</FORM>

coopster

8:54 pm on Jul 6, 2004 (gmt 0)

WebmasterWorld Administrator coopster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Validating to what standard? You may want to quote that attribute's value...
<form action="http://www.mysite.com">

[edited by: coopster at 8:55 pm (utc) on July 6, 2004]

ExpLarry

8:55 pm on Jul 6, 2004 (gmt 0)

10+ Year Member



You may also want to close those option tags (</option>).

mfmikeb

10:11 pm on Jul 6, 2004 (gmt 0)

10+ Year Member



Thanks...options closed.
But still a no go.
Trying to validate to html 4.01 transitional

tedster

10:25 pm on Jul 6, 2004 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



The snippet you posted will validate if you quote the attribute as coopster suggested. But without the quotes, I get the same error that you reported.
 

Featured Threads

Hot Threads This Week

Hot Threads This Month