Welcome to WebmasterWorld Guest from 54.162.155.183

Forum Moderators: incrediBILL

Message Too Old, No Replies

iframe question

Nothing after the iframe works

     
8:56 am on Aug 7, 2003 (gmt 0)

10+ Year Member



I've done a search of this site but I've been unable to find an answer to my problem.

I'm designing a page which contains an I frame the basic idea is all of my pages look the same except they are different colours and obviously content. All of the pages are going to be a table that is 740 x 320 no matter what screen res a user is using.

The table is split into 4 sections, the top is the Logo an Navigation, the left side is pictures and more Navigation the right side is the content and the bottom is the address details:

----------------------------------------
¦ Navigation ¦ Logo ¦
¦ ¦ ¦
----------------------------------------
¦ More Navigation & ¦ Content or ¦
¦ ¦ iframe ¦
¦ Pictures ¦ ¦
¦ ¦ ¦
----------------------------------------
¦Address Details Etc. ¦
----------------------------------------

When ever I stick my iframe code into my HTML the iframe works but anything after the iframe stops working.

Please can someone help as it is driving me mad!

9:08 am on Aug 7, 2003 (gmt 0)

WebmasterWorld Senior Member blobfisk is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Hey woody,

Have you closed the iFrame correctly in your HTML? It might be worthwhile running your HTML through the W3C validator and seeing if that spots any errors.

10:37 am on Aug 7, 2003 (gmt 0)

10+ Year Member



w3C validator?
10:42 am on Aug 7, 2003 (gmt 0)

WebmasterWorld Senior Member blobfisk is a WebmasterWorld Top Contributor of All Time 10+ Year Member



The W3C Validator [validator.w3.org] will check your markup against it's standards (and based on your doctype).

It is very useful in catching little markup errors and making sure that your code is compliant.

10:43 am on Aug 7, 2003 (gmt 0)

10+ Year Member



Woody have you closed the Iframe by using the </frame> tag because if you havnt then anything after the IF will not work correctly.

The validator can be found at www.w3.org just stick your details in and fix those errors...

11:01 am on Aug 7, 2003 (gmt 0)

10+ Year Member



Cheers guys helpful stuff.

I have got the </Frame> in there I falling at the first hurdle with DOCTYPE now lol I'll keep trying but thanks for all your help.

11:06 am on Aug 7, 2003 (gmt 0)

WebmasterWorld Senior Member topr8 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



>>I have got the </Frame> in there

assume thats a typo and you mean </iframe>

 

Featured Threads

Hot Threads This Week

Hot Threads This Month