Welcome to WebmasterWorld Guest from 54.234.38.8

Forum Moderators: rogerd & travelin cat

Message Too Old, No Replies

media library, widget issues working on my theme

     
9:10 am on Mar 4, 2014 (gmt 0)

New User

joined:Mar 4, 2014
posts: 10
votes: 0


Hi,

I have two problems on my wordpress theme.

1st :

when i edit a post, and i click on the add media button, my media library is empty (like if everything works but without images !) (obviously i have some images in the library, it's not really empty)

And when i try to upload a media in this part it gives me an error ( but the image is even uploaded.

2nd:

When i drag and drop a widget in the sidebar, for example, it closes directly !
And that for all the widget in all the sidebar

You can see the screenshots.

thanks for reply

[edited by: lorax at 12:05 pm (utc) on Mar 4, 2014]
[edit reason] No URLs please [/edit]

12:10 pm on Mar 4, 2014 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member lorax is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Mar 31, 2002
posts:7575
votes: 0


Hello creale,
Welcome to WebmasterWorld. There are two likely causes. File permissions and a plugin conflict.

File permissions can be found here: [codex.wordpress.org...]

Read the section on Troubleshooting on this page: [codex.wordpress.org...]
4:08 pm on Mar 4, 2014 (gmt 0)

New User

joined:Mar 4, 2014
posts: 10
votes: 0


I've disabled all my plugins and i still have my problems ...

I do have problems with the permission of my site ... Sometime i can't just overwrite a file by FTP ...

I've put chmod 777 to all my files to see if the problem stopped ... :( No

but if i disable my theme ... everything all right !

It's my theme but where is the problem ?

I searched on google but I do not have a specific answer, some even speak of space in the file function.php

But if it's that i have to check all my included files too ..

Any idea.. strange problem

I've install wp in local too, i will on it and tell you

Good afternoon
6:43 pm on Mar 4, 2014 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member lorax is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Mar 31, 2002
posts:7575
votes: 0


Is this a custom theme or built by a theme author? If authored by someone else, then visit their support page or contact them directly and see if they can help you out.

If not, then you may have some long nights ahead of you. You'll need to troubleshoot several files to uncover the issue. There won't likely be a clear answer but rather hints of what the issue might be. That space in the functions.php file sounds familiar. Make a copy of the original as something else like functions.orig then work with the original. This way if you make a horrible mistake you can get back to where you started.
8:49 pm on Mar 4, 2014 (gmt 0)

New User

joined:Mar 4, 2014
posts: 10
votes: 0


Thanks for your answer, it's a custom theme that i'm developping !

I thought that i certainly might work a lot to recovery that problem.

I've done some save, but it seems that those issues are running for some time !

So i've to check all my files looking for every spac ?

Can you tell me where i must search those space intruder ? :)

What is the programming rules ?

thanks a lot for helping me on this
2:06 pm on Mar 5, 2014 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member lorax is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Mar 31, 2002
posts:7575
votes: 0


Hi creale,
I'm sorry but I won't be able to help you troubleshoot the issues. You really should read the CODEX at WordPress.org [codex.wordpress.org...] It has everything you need to know.
8:40 pm on Mar 6, 2014 (gmt 0)

New User

joined:Mar 4, 2014
posts: 10
votes: 0


It ok i have fixed all !

white space problems
12:59 am on Mar 7, 2014 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member lorax is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Mar 31, 2002
posts:7575
votes: 0


Wonderful! I'm glad you got it sorted!
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members