Welcome to WebmasterWorld Guest from 54.162.184.214

Forum Moderators: coopster & jatar k

Do we need new PHP Version for AMP implementation?

Which version of PHP will support AMP tags.

     
10:03 am on Nov 23, 2017 (gmt 0)

New User

Top Contributors Of The Month

joined:Nov 11, 2017
posts: 6
votes: 0


Do we need new version of PHP to implement AMP? I am using PHP version 2.0 and it's showing error in console logo. Please answer for this.
1:30 pm on Nov 23, 2017 (gmt 0)

Senior Member

WebmasterWorld Senior Member Top Contributors Of The Month

joined:Apr 1, 2016
posts:1863
votes: 470


AMP is simply modified and constrained HTML. The use of AMP should have no impact on your choice of PHP version. Now if you are using a CMS like wordpress and you are using a plug-in to convert your pages, then that may be a different situation. But that has to do with your CMS and plug-in and not AMP.

it's showing error in console logo.

What exactly is throwing the error? Is it a PHP error or an AMP error?
7:12 pm on Nov 23, 2017 (gmt 0)

Administrator

WebmasterWorld Administrator phranque is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Aug 10, 2004
posts:11279
votes: 133


Welcome to webmasterworld, Amar!

Did you see that error in the server error log file?
9:13 pm on Nov 26, 2017 (gmt 0)

Junior Member from US 

5+ Year Member

joined:Dec 23, 2008
posts:155
votes: 4


PHP version 2.0

Huh!?
4:19 pm on Nov 27, 2017 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Dec 15, 2003
posts:2610
votes: 0


PHP is at version 7.1

The minimum stable version for most system is 5.6 or greater, anything "new" should be running on 7.0 or greater.