Welcome to WebmasterWorld Guest from 54.205.251.179

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

premature-end-of-script-headers: php-cgi referrer

   
12:21 am on Apr 30, 2013 (gmt 0)



With a shared hosting web company, running on Linux based web server. Sites occasionly goes down with the aforementioned error being the most prolific error showing in the logs.

The site goes down for 2-3 hours before working again. During this time all calls to a PHP file stall for 60 seconds before getting an Error 500 message. (html, css and images work fine).

Even simple PHP scripts that contain NO php code don't work.

Spoke to web host (useless tech support, sigh) who are adament that the error is on my side - somehow. they claim other sites on the server are working fine. makes no sense since NO php codes work, even a php script that contains no php code.

:S

Any ideas?

Thanks in advance.
12:42 am on Apr 30, 2013 (gmt 0)



another error in the logs shows -

Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request function
1:17 am on Apr 30, 2013 (gmt 0)

WebmasterWorld Senior Member leosghost is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



Even simple PHP scripts that contain NO php code don't work.

How can a php script contain "no php code" ?

That is like saying "a sentence that contains no letters"..

What have you got ? ..remove any identifying elements that might lead someone to your site..
1:21 am on Apr 30, 2013 (gmt 0)



i mean its a .php file that contains only HTML code.

essentially its a .php file called test.php and contains -

<html><head><title>test</title></head><body>TEST</body></html>

basically its just a test php file to see if any of my php code was causing the error messages to appear. but even the test.php file will not load.
1:34 am on Apr 30, 2013 (gmt 0)

WebmasterWorld Senior Member swa66 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Why not go simple: switch providers.
1:49 am on Apr 30, 2013 (gmt 0)



because I want to make sure its me at fault and not them first. If it does appear to be an issue with them the I will do that. the host is streamline.net and TBH I only hear bad things about them so probably will eventually change hosts.
1:50 am on Apr 30, 2013 (gmt 0)



*them at fault and not me
2:12 am on Apr 30, 2013 (gmt 0)

WebmasterWorld Senior Member leosghost is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



Ah :) ..was busy "elsewhere" and so didn't see that you had replied and that swa66 had got back to you..( my apologies for being a bit "literal" , but one never knows :) ..over in the htaccess threads they get a lot of "it doesn't work"...I thought you might be similar..

Never heard of your host..but I'd agree with swa66..make them your exhost..:)