Welcome to WebmasterWorld Guest from 107.20.54.98

Forum Moderators: incrediBILL

Message Too Old, No Replies

png images disappearing in IE7/IE8

png images disappearing in IE7/IE8, not on localhost

     
6:38 pm on Apr 7, 2009 (gmt 0)

New User

5+ Year Member

joined:Apr 7, 2009
posts: 4
votes: 0


I am experiencing a very strange png-disappering bug in IE7/IE8.
The problem is that it happens only on the remote server (running IIS6), but not on localhost(running IIS7).
I know about (and have tried to fix) several known issues, such as the absolute/float bug ( [brunildo.org...] ).
I am also using pngfixes for IE6, I have tried to remove them completely, without any luck.
It is just some images which are disappearing, not all.
Here is some of the HTML where image disappear:


<div id="RightContent">
<div class="InfoBubble">
<img id="DefaultControl1_InfoBubble1_FavCircle" class="FavCircle" alt="Send inn" src="Gfx/fav_circle.png"/>
<h1>headline text dine kulturminner</h1>
<p>text text text text text text text text text text tex text text text tex text text text text text text text text text text text text text</p>
<p></p>
<p>text text text text text text tex text text text tex text text text text text text text text text text text text text text text text text</p>
</div>
<div class="ClearBoth"/>
.......

Here is the related CSS for these elements:

#RightContent
{
float: left;
}
.InfoBubble
{
font-family: Helvetica, Arial;
font-size: 12px;
font-weight: normal;
color: #000400;
margin: 40px 0px 0px 31px;
padding: 56px 57px 56px 66px;
width: 444px;
height: 215px;
background: url(../Gfx/bg_infobubble_82.png) no-repeat left top;
}
.InfoBubble .FavCircle
{
position: absolute;
top: 115px;
left: 560px;
z-index: 100;
}

Any help appreciated! Thanks!

[edited by: tedster at 8:32 pm (utc) on April 7, 2009]
[edit reason] make link clickable, add boxes [/edit]

11:22 pm on Apr 9, 2009 (gmt 0)

Senior Member

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:May 26, 2000
posts:37301
votes: 0


Do the png images show up fine in other browsers?
11:27 pm on Apr 9, 2009 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:May 21, 2001
posts:2149
votes: 0


../Gfx/bg_infobubble_82.png

Are you sure the remote server is pulling this image from the correct location (which might seem ok locally). Just for fun try making the location:

http://www.example.com/Gfx/bg_infobubble_82.png

and same for the other image

12:52 pm on Apr 10, 2009 (gmt 0)

New User

5+ Year Member

joined:Apr 7, 2009
posts:4
votes: 0


Hi, and thanx for replies!

The images show up fine in other browser.
In IE7/8 I can also see the png for 1/10 sec, and then it disappears. So it seems like it is loading from the right location.

3:18 pm on Apr 14, 2009 (gmt 0)

Preferred Member

10+ Year Member Top Contributors Of The Month

joined:July 23, 2004
posts:472
votes: 35


A small suggestion if I may?

.PNG is pretty heavy.

I might suggest that you convert to the lighter, easier and faster loading .JPG or .GIF.

I've had some of the same issues with the .PNG over the years, and at times still do, but only from the local host end.

3:32 pm on Apr 14, 2009 (gmt 0)

New User

5+ Year Member

joined:Apr 7, 2009
posts: 4
votes: 0


Hi mcneely!
I have thought of it, but the design requires smooth transparency, and therefore i must use .png
7:29 pm on Apr 14, 2009 (gmt 0)

New User

5+ Year Member

joined:Apr 7, 2009
posts:4
votes: 0


I just found out what was causing the error...
There was a old reference to pngbehavoiur.htc (png fix for IE6), which did not show in source, but when I removed it, everything works as it is supposed to.

Sorry for wasting your time :(