Welcome to WebmasterWorld Guest from 54.160.244.240

Forum Moderators: Robert Charlton & aakk9999 & andy langton & goodroi

Message Too Old, No Replies

Google "Links to Your Site" :: Shows Links to Another Domain

     
3:55 pm on Jun 3, 2013 (gmt 0)

New User

joined:June 3, 2013
posts: 2
votes: 0


Background: My company manages multiple domains -- our software, our client pages, and our sales site each have a separate domain. Only the sales site is accounted for in Webmaster Tools; and each of these domains are managed separately in GA.

Problem: In Webmaster Tools (for our sales site), the "Links to Your Site" page is made up primarily of links to another domain (our client pages). I'm not sure why this would happen -- and I'm frustrated by what it does to our data.

For clarification: I'm looking at the "all linked pages" page -- so the problem is *not* that I'm looking at our pages linking to us. Rather, Google seems to know that these pages belong to the same owner, and is not making the distinction by domain. (If I hover over the links, in fact, they appear to show the sales domain before the directory & file string -- resulting in a link which is actually invalid, and which has always been invalid.)

Thanks,
Jessica
5:08 pm on June 3, 2013 (gmt 0)

Preferred Member

10+ Year Member

joined:Aug 13, 2002
posts:408
votes: 0


Could it be that you are using the same IP address for both domains? This isn't normally an issue but it may have confused the bot.
5:18 pm on June 3, 2013 (gmt 0)

Moderator from US 

WebmasterWorld Administrator martinibuster is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Apr 13, 2002
posts:14078
votes: 166


Similar to previous response, sometimes your IP can change, with your former IP assigned to the other site...
5:28 pm on June 3, 2013 (gmt 0)

New User

joined:June 3, 2013
posts: 2
votes: 0


It's not the same IP -- and while it's possible that at one point these domains shared an IP address, that would be a minimum of three years ago (more likely 5). The entries in "Links to Your Site" are all from 2011-2013, so that doesn't seem the likely cause. :(
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members