Welcome to WebmasterWorld Guest from 54.198.93.179

Message Too Old, No Replies

Images not getting indexed by the Googlebot-image

     
11:19 pm on May 11, 2011 (gmt 0)

5+ Year Member



I know this topic has been discussed before and I found some great tips in this forum, but unfortunately my problem still remains. My website is about a Caribbean destination, I put it online 11 years ago. My site contains hundreds of images but none of them have been indexed by the GoogleBot-Image. When I do a Google Image search on my website (site:mydomain.com) ... no result.

I tried many things that was suggested in this forum:
- primary keyword in the image filename
- relevant Alt text in my img tags
- caption with relevant keywork phrase

Here's the content of my robots.txt file:
User-agent: *
Allow: /

Because of the nature of my website, I really think I would get more traffic if my images would appear in a Google Image search.

Do you have any idea on what else can I check or do?

Lily
2:50 pm on May 12, 2011 (gmt 0)

WebmasterWorld Administrator goodroi is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



I'm curious how strong your website is. How many backlinks does your site have? Has Google indexed most of your pages and is it ranking them?

Have you checked your log files to see how often googlebot is visiting you?
4:06 pm on May 12, 2011 (gmt 0)

5+ Year Member



The homepage of my website has a page rank of 3/10 most other pages in the site have a page rank of 2/10. When searching the name of this Caribbean destination in Google Web my website is always in the first position of the search result since the last 10 years. The googlebot visits my site regularly but the Image Bot never index the images.
11:15 pm on May 12, 2011 (gmt 0)

5+ Year Member



Hi Lily,
there are allways four points to be checked:

1. Can the robot index your images (robots.txt)? [yes]

2. Can the robot find your images? (is the url of the image in the html-source-code? )

3. How often visit the imagebot your pages? Usually: the more frenquently you upload new images the higher is the crawling-rate. In my experience: if you upload every week a new pivture it took about 2 weeks until new images are indexed. If you upload one per day it took about two days. (Long term) frequency is an important signal for the bot.

4. Perhaps your images are indexed but you didn't see them. Have you checked the "safeSaerch-Filter"? Make an image-search for "site: yourdomain.tld" and the switch between "Filter: moderate" and "Filter: Off".

Good luck
Martin
3:17 pm on May 13, 2011 (gmt 0)

5+ Year Member



Bingo! When I switch the image-search to "Filter: Off" then I see 1700 results! thanks Martin!

But now... Is there a way to change the "unsafe" status of my domain with Google? I don't have any adult content in it.
4:42 pm on May 13, 2011 (gmt 0)

5+ Year Member



First you should ask yourself: are the images ok for children.
If so, the problem is mostly the text. I guess you have too many words in it that may be "offensive". In my experience there is a "critical border" - if you have too many of those words all of your images are filtered out.

Concrete: check your site for "offensive words" - like this:
"site:yoursite.tld xword". eg. sex, sexy, hot, #*$!, naked etc (I don't want to destroy the trust of this forum ;-) )

Delete all these words.

When your text is clean (and of course your images) you should ask Susan in this "Webmasterheld-Thread":
[google.com...]

If your site is clean it will be automatically reindexed in the "moderate imagesearch". But this process takes about 6 - 9 months (in my experience). If you ask Susan directly it takes about 7 - 14 days.

Good luck
Martin
 

Featured Threads

Hot Threads This Week

Hot Threads This Month