Welcome to WebmasterWorld Guest from 50.19.135.67

Message Too Old, No Replies

Google Image update - 28 April, 2010

     

zeus

11:29 pm on May 5, 2010 (gmt 0)

WebmasterWorld Senior Member zeus is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Hello

I did not have the time to write, but here is, Google image had a little update again and I guess you all have seen the new design which was launched a Month ago, which I think is pretty ok, as long they still show content provider page in full when a icon is pushed.

I have noticed search with "SafeSearch moderate on" has once again added more images to that filter which before was not there, which is of cause a good thing for the search quality, so once again nothing to complain about, which has also been the case now for some time, so it looks like Google image is finally stable.

A site of mine have lost all images , but 2 in safe search filter on, thats a little weird be cause nothing was done to the site or links added, so now im wondering if a ad could be the reason, I will have a look, I think such things are always interesting to solve and special since last year when you dont have to wait 3 Month for a image update.

Thats it, not much action, but once again im positive on the Google image results.

tedster

5:56 am on May 6, 2010 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Thank you for keeping us updated, zeus. With so much attention going to Caffeine, the new Jazz interface and the MAYDAY SERP changes, it's good to hear about improvements in Image Search, even if they are incremental rather than earth-shaking.

Drew

12:16 pm on May 6, 2010 (gmt 0)

10+ Year Member



Thanks Zeus! Have you seen the images coming from different sources (e.g. more authoritative sources) when filtering is enabled?

mssfldt

10:49 pm on May 6, 2010 (gmt 0)

5+ Year Member



Hi,
yes, agree. There are new pictures in the index. The "deadline" in my (german) galleries seems to be around March 15. No newer pictures of mine are indexed.

Did you see the change in the algo. I called it "variety factor". If you check e.g. the image results for "mona lisa". Some month ago the first page looks like the actual page 7. And the actual serp 1 is a funny mixture of many variations of the picture. (Now its a little bit like bing.)

Did you see this : please scale your browser that it shows 7 picture per row. Then search for "albert einstein". In my browser the result no. 1, 22, 43 are different versions of the same picture. Also result 2, 23, 44, or 4, 25, 46. Its really funny - seems that google wants to show the same pictures on every result page.

Greetings, Martin

steveb

11:37 pm on May 6, 2010 (gmt 0)

WebmasterWorld Senior Member steveb is a WebmasterWorld Top Contributor of All Time 10+ Year Member



There is no explaining why the moderate search filters out images it should not, but the quality of the results has gotten much worse because of it the last two updates.

Something pretty seriously wrong there at Google images.

tedster

11:48 pm on May 6, 2010 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



mssfldt - interesting observations.

We normally don't accept search keywords in posts here, but I will make an exception for those two terms. Just don't want to see this thread flooded with other keyword searches, please.

mssfldt

7:17 am on May 7, 2010 (gmt 0)

5+ Year Member



hi tedster,
thanx and sorry. Next time I try to describe ;-)
Martin

macas

11:41 am on May 7, 2010 (gmt 0)

5+ Year Member



No changes here , everything still the same in GI. :-)

mslina2002

6:13 pm on May 16, 2010 (gmt 0)

10+ Year Member



Just checked analytics, and referrals from Google images has dropped to zero since May 5 while at the same time the bot has been crawling my site like crazy and added more images being indexed by looking at the site: command. It is just that the referrals have been flatlined.

Anyone seeing similar in their stats referral?

steveb

10:24 pm on May 16, 2010 (gmt 0)

WebmasterWorld Senior Member steveb is a WebmasterWorld Top Contributor of All Time 10+ Year Member



You probably were inappropriately safe filtered.

sklosed

8:57 am on May 17, 2010 (gmt 0)

5+ Year Member



mslina2002 - seeing the same. Big jump in images indexed, but referrals have dropped to nothing. Last normal day was the 5th May, then dropped to nil referrals by the 7th.

Mentat

11:21 pm on May 24, 2010 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member Top Contributors Of The Month



Now I see that the referrals from Google Images os 0 since 7th of May!

speedshopping

2:24 pm on Jul 3, 2010 (gmt 0)

10+ Year Member



you may want to look at this as it will probably explain why you are not seeing referrals...

[google.com...]

tedster

6:09 pm on Jul 3, 2010 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Thanks, speedshopping. That's a very useful Google Help Forum thread - so let's put the quote here:

on may 6, google analytics changed the way they report accesses from google image search. in "traffic overview" they used to be seen from images.google.com (referral), now most of them are included in "google.com (referal)".

so even if google analytics seems to show the referals from image search dropping to 0 since may 6, that's in fact no the case at all.

hugh

1:37 pm on Jul 4, 2010 (gmt 0)

5+ Year Member



For the last week I've been seeing a third less images reportedly indexed since he last update stabilized a month ago...
 

Featured Threads

Hot Threads This Week

Hot Threads This Month