Welcome to WebmasterWorld Guest from 54.167.46.29

Message Too Old, No Replies

Google site performance and banner rotation scripts

     
10:16 am on Apr 22, 2010 (gmt 0)

Full Member

5+ Year Member

joined:July 11, 2008
posts:210
votes: 0


Hi all,

I have an issue whereby my site is in the 12-13 seconds bracket in WMT site performance.

This is obviously a concern but i cant understand why it is slow, it loads fine for me, WMT bot crawl data suggests the same, and so do many people i have asked to test it from around the world.

The only thing i can find is i run a banner rotation script, that refreshes a banner every 60 seconds, so if you load a page and stay there for 30 mins, that banner will load many times over.

Could this be causing the issue? Technically the pages never finish loading, as the banner keeps going, indefinitely.

Would having the banners load from another domain fix this do you think?

Thanks.
5:04 pm on Apr 22, 2010 (gmt 0)

Senior Member

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:May 26, 2000
posts:37301
votes: 0


Have you used any of the Page Speed tools? It seems unlikely that a banner refresh after 60 seconds would give you a load speed of 12-13 seconds.
12:42 am on Apr 25, 2010 (gmt 0)

Full Member

5+ Year Member

joined:July 11, 2008
posts:210
votes: 0


I have tried Web Page Analyzer - 0.98 as advised by Google, it reported 20s load times, which I dont get, neither does anyone i asked to test from many worldwide locations.

Regardless i made a lot of changes and got it dow to 6s, 80% reduction. So i will wait and see what WMT reports, hopefully an 80% drop.
1:10 am on Apr 25, 2010 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Feb 27, 2003
posts:732
votes: 0


Have you tried Firebug's Net tab to see how all the page elements load?