Welcome to WebmasterWorld Guest from 54.163.40.152

Message Too Old, No Replies

Google has page cached, but URL search yields no results

     

Jessica

1:41 am on Apr 22, 2010 (gmt 0)

10+ Year Member



Guys, what could be wrong? Google seems to have spidered the page and has it cached ( It is a snapshot of the page as it appeared on 9 Feb 2010 23:57:08 GMT) but if I search for he page URL in google, it doesn't return it.

Could that mean some problem?
And why the last cache was only on 9 Feb (almost 3 months ago)

tedster

4:37 am on Apr 22, 2010 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I don't think anything is wrong with your site - I think Google has a data glitch. Someone else here reported a similar oddity, I think it was that the page was getting search traffic but didn't even show up on a URL search.

gn_wendy

8:28 am on Apr 22, 2010 (gmt 0)

5+ Year Member



i have been having trouble with the URL and site:-command

a keyword search will return a page, and a link to the cache. I can visit the cache page. The page get's traffic (ranks #3) for a semi-longtail keyword with 10-100 clicks per day. Has been stable for a few weeks now.

site:example.com/dir/sub-dir/page does not have any results.

seoN00B

9:15 am on Apr 22, 2010 (gmt 0)

5+ Year Member



Ive noticed that many times. Google detects that you are doing link building.

What i do is I removed all recent links. After 3-5 days it is back.

gn_wendy

12:21 pm on Apr 22, 2010 (gmt 0)

5+ Year Member



Google detects that you are doing link building.

What i do is I removed all recent links. After 3-5 days it is back.


The page IS indexed, there IS a page in the cache and the page DOES SHOW for its keyword and DOES GET traffic.

the only thing not working is the site:-operator for that specific URL ... I am with tedster on it being a data glitch.

seoN00B

6:22 am on Apr 23, 2010 (gmt 0)

5+ Year Member




The page IS indexed, there IS a page in the cache and the page DOES SHOW for its keyword and DOES GET traffic.

the only thing not working is the site:-operator for that specific URL ... I am with tedster on it being a data glitch.


Sorry im replying on Jessica's post.

On what ive experience.. the page is cached but if you search the URL it is not on the search results. weird.

tedster

6:27 am on Apr 23, 2010 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I also have been seeing this glitch for a long time:

site:example.com does NOT show a certain URL, but
site:example.com/directory/ DOES show that URL

Unfortunately, the site: operator is not all that dependable.
 

Featured Threads

Hot Threads This Week

Hot Threads This Month