Welcome to WebmasterWorld Guest from 54.145.39.186

Message Too Old, No Replies

Back links not showing in Google Webmaster Tools

     

kinley

12:03 pm on Sep 22, 2009 (gmt 0)

5+ Year Member



Hey,

We have build a news website a couple of months back.

Recently (10 days), I started link building using directory, article, RSS, blog submissions etc.

After all these submissions, I am still not able to see any back links in the "links to your site" section in the Webmaster Tools dashboard.

Is it that Google takes times to display this data or there is something more into it?

FYI, Google caches all these submission sites daily

tedster

4:42 pm on Sep 22, 2009 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Yes, there is a time delay for reporting in GWT. There is also another factor at play - Google does not report all backlinks to the site owner. Some members here recently reported as high as 40% missing.

kinley

3:23 am on Sep 23, 2009 (gmt 0)

5+ Year Member



Thanks tedster for the inputs.

How much delay can we expect until GWT shows our back links.

And, is there any other way by which we can get to see all of our back links (if not in GWT)?

Thanks.

tedster

12:01 pm on Sep 23, 2009 (gmt 0)

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member



There is more complete public information about links available from Yahoo Site Explorer - but it's still limited to 1,000.

With regard to the time delay in WMT reporting, it fluctuates - there's no particular time period you can depend on.

kinley

12:11 pm on Sep 23, 2009 (gmt 0)

5+ Year Member



yes, I had checked out Yahoo site explorer as well.

Can we filter the results there, example: can we exclude back-links from xyz.com from the total results.

 

Featured Threads

Hot Threads This Week

Hot Threads This Month