Welcome to WebmasterWorld Guest from 54.225.55.88

Forum Moderators: Robert Charlton & aakk9999 & andy langton & goodroi

Message Too Old, No Replies

Webmaster Tools shows sitelinks but they're not in the SERPs

     
9:11 pm on Jan 31, 2008 (gmt 0)

Junior Member

10+ Year Member

joined:July 14, 2004
posts: 83
votes: 0


When I log into Google Webmaster Tools and check to see if my site has sitelinks, it shows eight sitelinks that are supposedly live. However, these links never actually show up when I perform a search in Google.

I've tried branded terms and non-branded terms that match the actual sitelinks pages showing up in Webmaster Tools, but nothing seems to work.

Has anyone ever experienced this? Is it somehow a glitch?

9:31 pm on Jan 31, 2008 (gmt 0)

Senior Member

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:May 26, 2000
posts:37301
votes: 0


No, it's not a glitch - in fact it's very common. The list you see in Webmaster Tools is what the generation part of the algo has chosen to display -- IF the rest of the algo determines to display sitelinks at all for some search or other.

The most common query to display sitelinks is the domain name - with or without the tld extension. But even searching on those most closely associated terms, there's still no certainty that the sitelinks will be displayed.

[edited by: tedster at 12:21 am (utc) on Feb. 1, 2008]

10:02 pm on Jan 31, 2008 (gmt 0)

Junior Member

10+ Year Member

joined:July 14, 2004
posts: 83
votes: 0


Thanks for the feedback, Tedster!
12:02 am on Feb 1, 2008 (gmt 0)

Full Member

10+ Year Member

joined:Mar 31, 2005
posts:337
votes: 0


Yeah, I got very excited the first time I saw this in w/master tools... then it wasn't there in Google.
12:06 am on Feb 1, 2008 (gmt 0)

New User

10+ Year Member

joined:Sept 7, 2005
posts: 23
votes: 0


same here, got the links in WMT, but no links in serps for any keyword combinations :( major let down.
7:31 am on Feb 1, 2008 (gmt 0)

Moderator This Forum from US 

WebmasterWorld Administrator robert_charlton is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Nov 11, 2000
posts:11438
votes: 202


A domain has got to be dominant for a particular query to get Sitelinks. I haven't come up with a simple description of how dominant, though. Each time I think I've figured it out, I come up with an exception.
8:48 am on Feb 1, 2008 (gmt 0)

Junior Member

5+ Year Member

joined:Aug 18, 2006
posts:83
votes: 0


today my sitelinks in gwt dissappeared again - damn never saw them ... - i hope they will come back...
9:09 am on Feb 1, 2008 (gmt 0)

New User

10+ Year Member

joined:Sept 7, 2005
posts: 23
votes: 0


mine too, just checked them abobut 8 hours ago, all fine, but now gone! very odd.

maybe they have decided to only display them in WMT if they are likely to appear in the serps...

10:01 am on Feb 1, 2008 (gmt 0)

New User

5+ Year Member

joined:Jan 19, 2007
posts: 15
votes: 0


maybe they have decided to only display them in WMT if they are likely to appear in the serps...

Not true in my case. They have disappeared from GWT for all my sites even ones that DO have sitelinks for a given search in Google.

12:38 pm on Feb 1, 2008 (gmt 0)

Junior Member

5+ Year Member

joined:Aug 18, 2006
posts:83
votes: 0


strange - i tried all searches and all keywords out of my logfiles and NOTHING - i can't see them - ARGHHH
1:18 pm on Feb 1, 2008 (gmt 0)

Senior Member

WebmasterWorld Senior Member 5+ Year Member

joined:July 26, 2006
posts: 1619
votes: 0


the ones that show up to me are either so old, non relavent or scraper links. All the good ones .. the ones I get google alerts about never show up in WMT and havn't for 2 years now.

Wish there was a way to disassociate our site from some of the links that do appear.

6:10 pm on Feb 1, 2008 (gmt 0)

Preferred Member

5+ Year Member

joined:Sept 28, 2007
posts:487
votes: 0


I actually saw them a week ago in the serps and took a snapshot but don't see them now. Probably a glitch. I am not sure that they somehow bring more traffic.
12:56 am on Feb 12, 2008 (gmt 0)

New User

5+ Year Member

joined:Feb 12, 2008
posts: 1
votes: 0


Had sitelinks disappear then reappear too, anyone figure out how to get it to display in the serps yet?
7:10 am on Feb 12, 2008 (gmt 0)

Preferred Member

10+ Year Member

joined:Dec 7, 2005
posts:636
votes: 0


Sorry rafiq, I'm to busy working on my time machine. The radiation burns really hurt.
1:11 am on Feb 28, 2008 (gmt 0)

New User

10+ Year Member

joined:July 10, 2004
posts: 8
votes: 0


I'm having the OPPOSITE problem, for over a week. sitelinks show for top search phrases, wow I'm lucky. Want to tweak them and remove the irrelevant one, but Webmaster Tools claims Google hasn't assigned any!

I'm srring this on 3 domains, wit hthe longet for a week now. At one point i looged out pf Personal search and the sitelinks disappeared, and I thought I had it figured out.

The next day though, sitelinks were back, even logged out, and they've stayed there, just not in WMT - bummer.

1:22 am on Feb 28, 2008 (gmt 0)

Senior Member

WebmasterWorld Senior Member tedster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:May 26, 2000
posts:37301
votes: 0


This phenomenon -- Sitelinks in the SERPs but not in WebmasterTools -- just started to be reported this past week s many sites started seeing Sitelinks in the SERPs for the first time. I'm assuming tht it's just a time lag that will get sorted out.

We've got a thread dedicated to that discussion, so I'm going to lock this one and take the future posting over to the newer thread:

Google Adds Sitelinks for a New Batch of Websites [webmasterworld.com]

 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members