Welcome to WebmasterWorld Guest from 34.229.126.29

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

Pear: command not found

Pear script not present after installation of PHP

     
5:39 pm on Jul 7, 2005 (gmt 0)

Junior Member

10+ Year Member

joined:Aug 14, 2002
posts:153
votes: 0


Hi. I've installed PHP 4.3.11 from source on to an OpenBSD i386 server however I've found out that pear script doesn't appear to be present. I discovered this when trying to install some pear packages doing "pear install packagename". I get a returned error of "-bash: pear: command not found". I've tried locating the pear script with locate and find but came up empty. I thought it might have been that the pear script was not in my path or execute permission not set however pear script is not present.

In the past it was located at /usr/local/bin/pear. I've checked and checked and it's certain that PHP should install pear. I've found the pear.conf, pear data, and pear libs but no pear script. In my situation I have to have PHP installed from source so my configuration requirements are met, therefore installing PHP from a package or port is not an option.

Please if anyone knows of how to resolve this problem please let me know! I've exhausted all ideas I can think of and this is my third day trying to resolve the problem. I've installed PHP 4 times now and still no pear script file found.

Thanks!

7:21 pm on July 7, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member ergophobe is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Apr 25, 2002
posts:8637
votes: 283


hmm.... I thought that with recent versions of PHP, PEAR was automatically installed in a subdir of the PHP install, so it would be at

/path/to/php/PEAR/

4:05 pm on July 8, 2005 (gmt 0)

Junior Member

10+ Year Member

joined:Aug 14, 2002
posts:153
votes: 0


Yes Pear is installed with PHP however I've not been able to locate the pear script file. I've found the installed directory of PHP but no reference to the pear script file which in the past was located at /usr/local/bin/pear.

I've been unable to locate a solution to this problem. I'll do whatever it takes to resolve this problem.

5:03 pm on July 8, 2005 (gmt 0)

Preferred Member

10+ Year Member

joined:Aug 28, 2003
posts:366
votes: 0


try running this:

find / -name 'pear'

Or:

find / -name '*pear*'

That should find the pear executable for you. If it doesn't then it's not installed and you've maybe missed a ./configure switch.

8:23 pm on July 8, 2005 (gmt 0)

Administrator

WebmasterWorld Administrator coopster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 31, 2003
posts:12548
votes: 2


You didn't compile PHP without it did you? From the PEAR installation pages ...


If you have a recent installation of PHP, you can relax: The PEAR base installation is already there, unless you have compiled your PHP with the ./configure flag --without-pear.

 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members