Welcome to WebmasterWorld Guest from

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

phpMyAdmin - Help please



12:31 pm on Jun 11, 2002 (gmt 0)

10+ Year Member

I'm trying to set up a little webserver on my local machine so that I can develop my skills a bit. - so it is purely for deveopment work. I am running XP and so far I have got Apached 2.0.36, Perl, PHP 4.2.1 all running fine. I am noe trying to get phpMyAdmin running, I have set things up in the config file as per the instruction, but now whatever I try, when I go to view [localhost...] (which is where I set it up) I return the error:
The $cfgPmaAbsoluteUri directive MUST be set in your configuration file!

The trouble is, I set that variable to 'http://localhost/phpMyAdmin/';

If anyone has any ideas on what I have done wrong I would be most appreciative.



4:42 pm on Jun 11, 2002 (gmt 0)

10+ Year Member

Twisty you are an absolute star, a life saver. It works - and all because you made sure I went to Sourceforge - they had exactly the same problem there! They didnt give the answer outright, but they made me check a couple of things.

First off I hadnt restarted Apache for ages, which probably didnt help.

But secondly I tried typing into browser:

That works.

I still can't make it work by putting in the browser:

But I guess thats just a small config issue, anyway, I dont care at the moment, it works.

Again, many thanks. I hope my troubles help someone else save a day of their time.


4:59 pm on Jun 11, 2002 (gmt 0)

10+ Year Member

Knowles, I missed your post again, sorry about that. That was another little trick I tried earlier to no avail. Thanks for taking the time to look though. I reckon it must be my fault for not restarting Apache, what a plonker!!


5:15 pm on Jun 11, 2002 (gmt 0)

10+ Year Member

No problem. To fix the localhost issue if you do a search in I do beleive its going to be winnt\system32\ or winnt\system32\drivers\etc (mine was here on win2k but its a workstation not a server)on win2k for HOSTS it should bring up a file. If you place in there: localhost
below the last address or comments and such it should fix that issue. I could be wrong. I know it worked on 98. I havent tried on XP yet.


1:00 am on Aug 22, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

// ;) Bugger. Nvrmind
This 34 message thread spans 2 pages: 34

Featured Threads

Hot Threads This Week

Hot Threads This Month