Welcome to WebmasterWorld Guest from 54.167.40.25

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

VNETShoutBox installation error- help needed

     
7:43 pm on Sep 1, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0


Hi there, i'm trying to install the VNETShoutBox to my site (running install.php), and i'm getting an installation error thru my browser which reads"

"You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') TYPE=MyISAM' at line 8"

this is the install.php script


require("./config.php");

###Install###
If($ssb[cmd]=="install") {

mysql_query("CREATE TABLE $ssb[pre]_shout (
sbid int(11) NOT NULL auto_increment primary key ,
sbname varchar(50) default NULL,
sburl varchar(50) default NULL,
sbshout varchar(255) default NULL,
sbdate varchar(50) default NULL,
sbip varchar(50) default NULL,
) TYPE=MyISAM;") or die(mysql_error());

mysql_query("CREATE TABLE $ssb[pre]_ban (
id int(11) NOT NULL auto_increment primary key ,
ip varchar(50) default NULL,
) TYPE = MYISAM;") or die(mysql_error());

mysql_query("CREATE TABLE $ssb[pre]_filter (
id int(11) NOT NULL auto_increment primary key ,
find varchar(50) default NULL,
replacewith varchar(50) default NULL,
) TYPE = MYISAM;") or die(mysql_error());

Echo("VNETShoutBox $ssb[ver] has been insatlled! Please Delete This file ASAP!\n");

###Not Installed###
} Else {

Echo("<a href=\"$_SERVER[PHP_SELF]?cmd=install\">Click here to install VNETShoutBox $ssb[ver]!</a>\n");

}
?>

I have all of the files in the same directory and it installs on my other site perfectly (diff host POWWEB, the problem im having here is with Lunarpages, whom I've contacted but they said for 3rd party I needed to fix it myself)

Lunarpages is using Mysql v4.0.20-standard and PHP v4.3.8

Powweb is using Mysql v4.0.15-log and PHP v4.3.8

Id really appreciate some help from you php masters...
thanks
løk

10:58 pm on Sept 1, 2004 (gmt 0)

Preferred Member

10+ Year Member

joined:Apr 17, 2002
posts:601
votes: 0


Seems like there is an extra , in the create lines at the end. If this is a prepackage script you may want to check there site to see if this has been reported. If not try to remove the extra ,'s and see if it fixes it. If it does it would probably be nice to report it to them. Also does it give a line number that it is erroring out on? The extra ,'s are in all of the create lines so if it does not error out on the first one thats not the issue.
11:37 pm on Sept 1, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0


yeah its a script direct from them and their site is being redesigned right now..

as for the extra ,

on what lines were you thinking that I remove them on, I removed them all and got a different error message so at this point im kind of at a loss for how to edit as im a php noob....

11:42 pm on Sept 1, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0


oh and yeah its giving an error on line 8 which when I check that in BBedit its a blank line after the "require("./config.php");

which lines are the create lines u mentioned?

thanks for the help I appreciate it....

strange this installed fine on my other hosting company....

11:49 pm on Sept 1, 2004 (gmt 0)

Administrator

WebmasterWorld Administrator jatar_k is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 24, 2001
posts:15755
votes: 0


what is the actual error message it gives for line 8?

remove commas on these lines

sbip varchar(50) default NULL,

ip varchar(50) default NULL,

replacewith varchar(50) default NULL,

as Knowles said
>> if it does not error out on the first one thats not the issue

but they don't belong there either

[edited by: jatar_k at 11:51 pm (utc) on Sep. 1, 2004]

11:50 pm on Sept 1, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0



You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') TYPE=MyISAM' at line 8
11:53 pm on Sept 1, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0


YOU ROCK JATAR.

that was it.

thank you so much.

løk

12:12 am on Sept 2, 2004 (gmt 0)

Administrator

WebmasterWorld Administrator jatar_k is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 24, 2001
posts:15755
votes: 0


not me, I missed it on first glance, that was all Knowles

good eye ;)

12:17 am on Sept 2, 2004 (gmt 0)

Preferred Member

10+ Year Member

joined:Apr 17, 2002
posts:601
votes: 0


HA! but it seems my time away has caused me to get even worse at my description skills. Guess I should have been more specific as to what ,'s I was talking about.
12:26 am on Sept 2, 2004 (gmt 0)

New User

10+ Year Member

joined:Jan 20, 2004
posts:30
votes: 0


you both rock ;)

thanks alot....