Welcome to WebmasterWorld Guest from 54.163.54.95

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

xcart Shopping cart

Installation problems

     
5:43 am on Apr 14, 2004 (gmt 0)

New User

10+ Year Member

joined:Apr 12, 2004
posts:6
votes: 0


Get this error message when trying to install
xcart

Ive read the installation and the manual but there doesnt seem to be any help with this error message

Warning: feof(): supplied argument is not a valid stream resource in /home2/australi/public_html/xcart/install.php on line 422
3:35 pm on Apr 14, 2004 (gmt 0)

Junior Member

joined:Sept 9, 2003
posts:107
votes: 0


set the chmod on your files to 777 while installing then reset them back to what they were. feof() just means it's looking the "end of file". It's probably not allowed to open a file so you get an error.
5:53 pm on Apr 14, 2004 (gmt 0)

New User

10+ Year Member

joined:Apr 12, 2004
posts:6
votes: 0


Ive reset every folder and files, double checking that they were all on 777.

Then went over and changed these files according to the install guidelines


site chmod 777 /www/xcart/
site chmod 666 /www/xcart/config.php
site chmod 755 /www/xcart/admin/spam.sh
site chmod 755 /www/xcart/payment/ccash.pl
site chmod 755 /www/xcart/payment/netssleay.pl
site chmod 755 /www/xcart/payment/verisign.pl
site chmod 755 /www/xcart/payment/wtsbank.pl

but I still get the same error message, I think my webhost is on holiday, so I guess im stuck
7:47 am on Apr 17, 2004 (gmt 0)

New User

10+ Year Member

joined:Apr 12, 2004
posts:6
votes: 0


Could the error be related to my path?
12:15 pm on Apr 17, 2004 (gmt 0)

Administrator

WebmasterWorld Administrator coopster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 31, 2003
posts:12541
votes: 1


The error message is directing you to the issue...what file is being used in the script,
/home2/australi/public_html/xcart/install.php
on line 422?

It could also be some directive settings, such as safe mode or url wrappers. The fopen [php.net] function page has a few troubleshooting tips you may want to check as well.

2:20 pm on Apr 17, 2004 (gmt 0)

New User

10+ Year Member

joined:Apr 12, 2004
posts:6
votes: 0


Thanks to all, installation complete
I deleted everything then uploaded and set up the mysql database again.

This time I used flashfxp to upload and set permissions.

Much better than using ws_ftp and dreamweaver.

I also uploaded in asii mode, would that have made any difference and i set the chmod to 7777 instead of 0777