Welcome to WebmasterWorld Guest from 35.172.195.49

Forum Moderators: coopster & jatar k

Message Too Old, No Replies

Newbie, PhpMyAdmin help needed

simple how to change/add categories query

     
3:49 pm on Dec 9, 2003 (gmt 0)

Junior Member

10+ Year Member

joined:Nov 4, 2003
posts:44
votes: 0


Hi All,

I am complete newbie at this so please bear with me. I recently set up a small auction site and we decided to have it tied in to a simple wap system for members only so that they can download some free ringtones for joining.

I asked a programmer to set up the wap site and he did a great job. However, he has set the categories to things like 'popular', 'modern', 'oldies' etc.....whereas I would much prefer to change this to the different phone manufacturers out there ie 'nokia', 'sony' etc. I have emailed him to no avail, so am hoping someone here will point me in the right direction. I am scared to touch it for fear of ruining the whole thing.

So how do I change them? It is asking for 'genure', 'song title' then 'url' to add the ringtones in (which I have managed to do). But everytime I edit the 'genure' for example, 'popular' to 'nokia' it still comes up as 'popular'. Please take pity on a newbie! Any help would be much appreciated.

Thanks!

4:08 pm on Dec 9, 2003 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:June 25, 2002
posts:776
votes: 0


Andy,

While it is hard to say without looking at the database, I am guessing that you need to edit the field in the table properties.

My guess is that your programmer used a data type of set or enum for the field genure. Data types let the database know what kind of information is going to be stored for the field - e.g. character data, numeric data, dates, etc.

With the data types of enum (short for enumerated) and set, the data stored in the database has to be of particular values (e.g, a set for color might be "red","green","blue").

Since "Nokia" is not part of the current set or enum, the database won't accept the value and is going to the default of popular.

Solving the problem: You mentioned that you are using PhpMyAdmin.
1) Click on the table name in the left hand window to bring up all of the fields in the right hand window.
2) Find the field genure and check the type type column - is it enum or set?
3) if it is enum or set, click on the change link.
4) in the tiny little form field that says "Length/Values" add Nokia (make sure to enclose it in the same type of quotes - single or double- as your other values. Make sure the values are seperated by commas (outside the quotes).
5) click save

You should now be able to change the ring types in the database to Nokia.

Good luck

5:11 pm on Dec 9, 2003 (gmt 0)

Junior Member

10+ Year Member

joined:Nov 4, 2003
posts:44
votes: 0


Hi There!

Thanks so much for the info! I was able to change genure to 'Phone Type'

Field Type Attributes Null Default Extra Action
Phone Type varchar(15) Yes NULL Change Drop Primary Index Unique Fulltext
song varchar(25) Yes NULL Change Drop Primary Index Unique Fulltext
url varchar(90) Yes NULL Change Drop Primary Index Unique Fulltext

However I still cannot get the 'secondary' categories to change. I can change them in myadmin, but when checking by phone the same 'popular', etc categories come up.

When I add a ringtone it changes straight away....for example I put it in popular, add title + url save and then check by wap it is there. But, if I edit , popular to nokia, title to 'nokia tones' and url....it changes on the page it doesn't show up on the phone and it's just the same old categories showing up :-( Surley it's got to be something REALLY simple I am doing wrong?

Thanks anyway for the above advice, at least I am not afraid to explore a bit now and if you or anyone else could shed some light I would be most grateful!

Thanks Again!

Andy

5:51 pm on Dec 9, 2003 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:June 25, 2002
posts:776
votes: 0


If it changes in the database, and changes on the web page, but not on the wap download, then I think the problem might be in the code that formats for wap.

This gets even trickier to diagnose without knowing your setup.