Welcome to WebmasterWorld Guest from 34.229.113.106

Forum Moderators: DixonJones & mademetop

Message Too Old, No Replies

Heads up for Awstats users

I'm getting your password in my log ;-)

     
2:58 pm on Aug 23, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member trillianjedi is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Apr 15, 2003
posts:7256
votes: 3


It's been an interesting afternoon browsing through all your logfile stats ;-)

I'm not sure if this is a bug, or the lazier types among you have just bookmarked your stats with your password in the URL.

When you click on my referral link, your entire URL is appearing in my logfiles, complete with password...

TJ

4:25 pm on Aug 24, 2005 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member jab_creations is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Aug 26, 2004
posts:3178
votes: 22


People are following links to your site using their passwords in the referal url you recieve from them you mean or?
4:28 pm on Aug 24, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member trillianjedi is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Apr 15, 2003
posts:7256
votes: 3


They're just clicking on my referral links in their log.

Their password is already in the URL. That's the problem.

Is this an Awstats bug? It seems very recent - I don't remember seeing this before.

TJ

4:33 pm on Aug 24, 2005 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member jab_creations is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Aug 26, 2004
posts:3178
votes: 22


Nah, who knows? I've never needed the password option for awstats so I can't help you there.
4:35 pm on Aug 24, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member trillianjedi is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Apr 15, 2003
posts:7256
votes: 3


You should never ever leave your stats open to public access.....
4:39 pm on Aug 24, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Aug 29, 2003
posts:944
votes: 0


Just checked it with a couple of AWStats installations and it is not happening - so it must be a configuration thing.
12:03 am on Aug 27, 2005 (gmt 0)

Junior Member

10+ Year Member

joined:Dec 28, 2004
posts:90
votes: 0


Sounds like a good reason to paste the URL into your browser address bar. No referring url.
6:44 pm on Sept 1, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:June 9, 2003
posts:1908
votes: 0


I've disabled my referer header anyway, but just to be on the extra-safe side, I never leave a sensitive page for another website, nor do I come to a sensitive page from another website. New tabs all the way! ;)
6:52 pm on Sept 1, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Feb 21, 2003
posts:2355
votes: 0


You should definitely forward your info to the AWStats guys, but I can't replicate what you are seeing with the latest beta, the latest stable, or the previous stable I just checked.
2:07 pm on Sept 9, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Dec 29, 2001
posts:1136
votes: 42


There is a recent awstats hack on linux. This hack involves a program called shellbot. Awstats is tricked into loading the worm into your /tmp or /var/tmp directory. The shellbot uses your bandwidth for various activities. Search GG for more information. Recently, I discovered I had been hacked by this. Though, I do not have awstats, someone was still able to trick one of my perl scripts into loading the program. the shellbot actually caused my system to crash (I lost money).
2:12 pm on Sept 9, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member trillianjedi is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Apr 15, 2003
posts:7256
votes: 3


Sorry, I had lost track of this thread.

It vanished quite quickly. I didn't get around to sending examples to awstats - didn't get time, but I haven't had any of these since.

Was very odd though. My guess is it was a bug.

TJ

4:18 pm on Sept 9, 2005 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member jab_creations is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Aug 26, 2004
posts:3178
votes: 22


I'm going to send you a sticky ...