Welcome to WebmasterWorld Guest from

Forum Moderators: phranque

Message Too Old, No Replies

FTP Error

Receive Error: Blocking Call Cancelled?



1:16 am on Mar 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

I'm doing some work on a client's server, and quite often, when I try and log in, I get the following message:

Receive Error: Blocking Call Cancelled

This will continue for several hours, and sometimes days and then out of the blue I'll be able to connect just fine. The client says that there is nothing wrong with their server, and I don't have any problem establishing an FTP connection anywhere else.

If anyone has some insight as to what causes this type of error message, I would greatly appreciate some help.


1:22 am on Mar 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

I used to run into that when I was running a blog. Blogger's servers would try to connect to mine to upload the new additions and would either timeout or get that 'Blocking Call' error. And of course sometimes it would work. The really weird thing was that it was to the same account on the same server as all my other domains but they all worked fine. Finally as a last resort I requested a new IP for the domain in question and the problem vanished instantly and has not returned even once. I know it doesn't make any sense but I swear it's the truth ;)


5:32 pm on Mar 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

Sounds like it could be a firewall issue - try switching to passive mode, or turning it off if it's on.


6:10 pm on Mar 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

I've tried all the reccomendations provided by IP Switch, including switching to passive and increasing the time out setting, but still no luck. It appears to be some type of problem with a router along the way.

I guess I'll need to convince them to set me up a server here in the U.S.


6:17 pm on Mar 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

WG I get the same problem all the time whereas others in the office don't. The blocking call problem has rendered my WSFTP 95 totally inoperable and most of the time LeechFTP does work and I believe I have the same settings on each. I tried changing firewalls and that wasn't the solution. I am definitely interested in anything you find out because it is a very annoying problem.


10:02 pm on Jul 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

I originally composed this for the *nix forum, but seems better suited here.

I've spent all day tracking down a problem that has plagued my network intermittently for a while, slow to establish telnet sessions, and FTP failing at times with !Error received: Blocking call cancelled

There's lot's of info on the net about this specific FTP error, but nothing helped. Most suggested setting FTP to passive mode or vise versa, others suggested lengthening the timeout value (which does work but is not a solution, waiting minutes for a session to be established).

Since none of the documented solutions helped I started looking closer at FTP, which eventually turned on the lightbulb that led me to DNS. When I set up BIND I didn't bother to set up the in-addr.arpa section for reverse resolution, thinking I didn't really need it based on previous experience with DNS.

Now after setting up the reverse resolution zone and the PTR records, FTP session establishment is lightning fast, and so is telnet session establishment.

Anyway thought I'd post it here since I saw many complaints when researching the problem from others that believed it to be slow servers at their ISP, or problems with their FTP client, or routing problems (spent hours looking at routes). Reverse resolution not being set up was never mentioned as a possible cause. Because of how FTP establishes a session I am now convinced that this is *the* problem when this error crops up, and I know there are ISP's out there running DNS without reverse lookup set up, or you may be unlucky enough to get a host/IP without a PTR record if they do have reverse lookup set up.

Anyway hope it helps someone else out there.


3:33 pm on Jul 29, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

Thanks Air.

I have the problem occur fairly often with several different clients. Now I finally have something to forward to their IT departments. :)


Featured Threads

Hot Threads This Week

Hot Threads This Month