Welcome to WebmasterWorld Guest from 54.162.227.136

Forum Moderators: incrediBILL

Message Too Old, No Replies

Hiding Forms With Layers

Netscape Help Needed

     
3:39 pm on Jun 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Anyone know a quick fix for hiding a form within a table within a layer in Netscape 4?

I am trying to hide the layer by putting another layer over the top of it unfortuently although it hides the rest of the form the form elements remain visible.

5:02 pm on Jun 28, 2001 (gmt 0)

10+ Year Member



I believe form elements *always* show above layers, according to my O'Reilly DHTML book at least.
5:22 pm on Jun 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Depends on exactly what you are trying to do but one good technique is to make the visibility property of the form hidden (or display:none) when the layer is over it.

Obviously this doesn't work if you have window like layers floating over the form (with bits peeking out).

5:36 pm on Jun 28, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Knighty...maybe instead of trying to hide it you should load it into the layer when called. MM exchange has a function "load url into layer" ;)
8:18 am on Jun 29, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Thanks guys, the problem is that I have a 4 main layers one of which has a form in it. To get all these aligned cross borowser I created 4 external CSS files which load depending on OS and browser. I then created 4 blank layers which basically hide the bottom portion of the layer giving the impression that the layer is being minimised/maximised I am using a function to toggle the visibility of the 'blank' layers.

I can't hide the layer with the form in it cos then the min/max image would vannish. And I can't really split the layer up into more layers cos it is a knightymare to align layers with forms etc.

I'm going to ivestigate Toolmans suggestion and hope that it solves my problem *fingers crossed*

10:19 am on Jun 29, 2001 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Problem Solved :)

I used a DW extension 'ClipLayer' which I've used before but for some reason thought not to use it this time - DOH!

Anways I removed all the hiding layers and just clipped the layer which makes the form elements dissapear.

Thanks for the input though :)

 

Featured Threads

Hot Threads This Week

Hot Threads This Month