Welcome to WebmasterWorld Guest from 54.204.165.156

Forum Moderators: incrediBILL

Getting Java plugin to work with Firefox on Linux

   
9:59 pm on Jul 15, 2004 (gmt 0)

10+ Year Member



When I try some of my favorite Java-driven sites,
they do not work with my Firefox 0.9.1, but bring
up a window that promises to install the plugin.
It seems to do a download, but Java does not end
up working.

Java is enabled.

How can I make this work? Environment: gentoo Linux,
Firefox 0.9.1, dual Xeon machine.

++ kevin

12:45 am on Jul 16, 2004 (gmt 0)

WebmasterWorld Senior Member encyclo is a WebmasterWorld Top Contributor of All Time 10+ Year Member



It's a pain, but I find he best way is to do it manually. If you have the plugin directly in the Firefox plugins directory, Firefox crashes. So...:

1: Install Java Runtime Environment from java.sun.com

2: Find the path to the plugin - on my system, it is:

/usr/java/j2re1.4.2/plugin/i386/ns610-gcc32

3: Find the plugins directory for Firefox - on my system, it is:

/usr/local/firefox-0.9.1/plugins

4. Create a Symlink in the Firefox plugins directory pointing to the plugin file

libjavaplugin_oji.so
:

ln -s /usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so /usr/local/firefox-0.9.1/plugins/libjavaplugin_oji.so

And restart Firefox. Hope that helps!

1:39 am on Jul 16, 2004 (gmt 0)

10+ Year Member



Thanks. That did it (modulo changing a few names
because I have the Blackdown kit).

++ kevin

3:58 am on Aug 11, 2004 (gmt 0)

10+ Year Member



I've followed exactly the steps described here. Now java works great in both Firefox and Mozilla as long as I run it as root. If I run it as regular user, Firefox will not launch at all, and while Mozilla will, it does not do java. I checked permissions, and they all seem okay. Is there something obvious or known I am missing? I am running Firefox 0.8, Mozilla 1.7, j2 runtime 1.4.2, RH linux 9.0. I've been trying to figure it out for the past couple of hours and am getting frustrated.
8:09 am on Aug 11, 2004 (gmt 0)

10+ Year Member



Well, after comparing a bunch of strace files I noticed that chrome.rdf now had
rw root root
which made it impossible for regular user to read. I changed that, firefox loads now without a problem, and then promptly crashes if I try to launch a java applet with a message:

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable

Still works fine if su'ed to root (with user's env). Bummer.
9:58 am on Aug 11, 2004 (gmt 0)

10+ Year Member



Got it to work to the point where it load and runs. Java applet appears to load, but cannot do anything in it. At the bottom it displays a message, "Applet sPass notinited" (if Firefox or Mozilla are launched as root, the message reads, "Applet sPass started"). I'll try to track this problem tomorrow.
 

Featured Threads

Hot Threads This Week

Hot Threads This Month