Welcome to WebmasterWorld Guest from 54.234.244.30

Forum Moderators: incrediBILL

Message Too Old, No Replies

CGI Scripts on localhost with FireFox

Firefox, cgi, iis

     
1:12 pm on Jan 11, 2005 (gmt 0)

New User

10+ Year Member

joined:Jan 11, 2005
posts:3
votes: 0


Happy New Year to one and all,

Can someone please help me. I am trying to get CGI scripts to execute on the localhost through FireFox, I have win2k using IIS, everytime I run a script I either get a prompt to save the script or the source code is displayed in the firefox browser window, has anyone else experienced this.

Thanks in advance

4:14 pm on Jan 11, 2005 (gmt 0)

Senior Member from CA 

WebmasterWorld Senior Member encyclo is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Aug 31, 2003
posts:9063
votes: 2


Welcome to WebmasterWorld [webmasterworld.com], sunburstyello.

It sounds like a mime-type problem. Does the same script work when using IE? In the CGI script, are you explicitly specifying the mime-type of

text/html
for the output? Finally, are you using a doctype on the output page, and does it make a difference if you remove it?
4:21 pm on Jan 11, 2005 (gmt 0)

New User

10+ Year Member

joined:Jan 11, 2005
posts:3
votes: 0


yes, IE is ok,
i use the text/html content type,
i have not tried the doctype, i will try it now, and thank you very much for replying.
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members