Welcome to WebmasterWorld Guest from 54.197.72.5

Forum Moderators: phranque

Message Too Old, No Replies

OpenBB been hacked - help needed

     
6:21 pm on Sep 13, 2005 (gmt 0)

New User

10+ Year Member

joined:Sept 13, 2005
posts:3
votes: 0


A friend running OpenBB 1.5 has had their message board hacked. I've been pointed in the direction of these boards for possible help.

Would really appreciate any pointers in getting it fixed. The board now reads: Hacked by Kinr (Russia).

Thanks!

7:23 pm on Sept 13, 2005 (gmt 0)

Junior Member

10+ Year Member

joined:Dec 20, 2002
posts:123
votes: 0


Words,
Welcome. The answer to your question can be pretty complex.

It would be very helpful to know how the system has been comprimised. Has the intruder gained root access (to the operating system) or has an OpenBB vulnerability been utilized (or both)? What was the exploit? Check the logs and search for descriptions of OpenBB exploits. In the meantime, your friend should take the machine off line. In the end, it will probably need to be scrubbed and everything installed from scratch (after you've found out what hole to plug).

Hope this helps you get started.

rharri

7:28 pm on Sept 13, 2005 (gmt 0)

New User

10+ Year Member

joined:Sept 13, 2005
posts:3
votes: 0


Thanks Rharri,

I'll point them to here in case they want to follow up on the details direct.

1:26 am on Sept 14, 2005 (gmt 0)

Full Member

10+ Year Member

joined:June 16, 2004
posts:232
votes: 0


there seems to be a recent SQL injuection exploit for OpenBB

Exploit PoC:
http://www.example.com/openbb/board.php?FID=[sql]
http://www.example.com/openbb/read.php?TID=[sql]
http://www.example.com/openbb/member.php?action=profile&UID=[sql]

3:41 am on Sept 14, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Feb 27, 2001
posts:2548
votes: 0


Try looking in a search engine for the term openbb. In the search I did 5 out of the top 10 results were about security problems. Seems like the fix might be to get another bb program.
12:29 pm on Sept 15, 2005 (gmt 0)

New User

10+ Year Member

joined:Sept 13, 2005
posts:3
votes: 0


Thanks for the pointers. The problem is now fixed (the person running the server kept a backup), but useful info in case it happens again.

I agree by the way that they should look to installing a better board in the long run.