Welcome to WebmasterWorld Guest from 54.163.168.15

Forum Moderators: open

Inktomi refuses to index site

   
1:49 am on Jul 4, 2003 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



We used to be #1 on inktomi and Hotbot since the 90's on some great keywords until a year or two ago. At some point we totally dropped out of the index. In May I paid Netsol to Surelist us and it appears we are finally "sorta" in the inktomi index, but we only get found (other than sponsored links on hotbot) if you type in the EXACT domainname.com. Rather useless huh? Even if you type in the full exact title of the page, half the page content, etc. Not #999, Nothing! We have top 10 listings all over google, and all the sites ranked near us everywhere else come up on hotbot when using the various filters, but our primary home page which was submitted is ALWAYS missing. Our surelist tracking on netsol says we've received 2 clicks in 2 months... both mine.
We haven't ever used frames on the submitted page (or most anywhere else). Have never done anything bad SEO-wise as evidenced by our other very high rankings. Have never had robots.txt files at all. We do, unavoidably have some repetition of our major keyword, but certainly not over 10% of the content. A part of our primary home page (which is NOT index.htm, but is in the root of our domain) IS mirrored on our domain root/index.htm, but that has never affected any other search engine that I know of.
I am totally stumped. Is it possible at some time in the past an inktomi editor manually blackballed us? I know one of our competitors edited us out of DMOZ after being one of the earliest entries there (and haven't been able to get back in since our category is permanently editorless). Is there a way to find out for sure and request it changed?
 

Featured Threads

My Threads

Hot Threads This Week

Hot Threads This Month