Welcome to WebmasterWorld Guest from 54.146.248.111

Forum Moderators: open

Message Too Old, No Replies

XML-Driven Flash files won't load the second time they are viewed inIE

Flash files don't load the second time they're loaded only in IE.

     

zachjones

5:36 pm on May 2, 2009 (gmt 0)

5+ Year Member



Hello everyone.

I have a problem that I have seen mentioned before, but am unable to find a resolution for.

I have two entirely different Flash files (both are driven by an XML file). You can see them on the home page of <snip> and by clicking Cabins, and then selecting a cabin, at <snip>.

Both of these files, for some users only, but not all, that use IE, will not display entirely or at all the second time they are viewed. For example, on the MMG site, view a cabin's page, go to a different cabin page, and then go back to the original cabin page. SOME users with IE (both v6 & 7) aren't able to view the slideshow the second time. Not everyone that uses IE has this problem, but all of the people that have the problem use IE.

It may be coincidence that they are both XML driven, not sure. I am at wit's end, and would be very grateful to anyone that has suggestions of any kind.

Thanks so much for your time!

[edited by: eelixduppy at 5:54 pm (utc) on May 2, 2009]
[edit reason] no personal URLs, please [/edit]

dreamcatcher

3:16 pm on May 6, 2009 (gmt 0)

WebmasterWorld Senior Member dreamcatcher is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Try adding a timestamp to your flash file. Assuming you use a PHP file, something like:

// PHP
flash.swf?t=<?php echo date("Y-m-d H:i:s") ?>

Might not work, but worth a try. Could be a cache problem.

dc

 

Featured Threads

Hot Threads This Week

Hot Threads This Month