Welcome to WebmasterWorld Guest from 54.158.240.147

Forum Moderators: ergophobe

Message Too Old, No Replies

Not able to link Home Page from my Articles in Joomla

     
6:51 am on Sep 29, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:May 26, 2009
posts: 117
votes: 0


Hey,

I think my question would be too Joomla specific but need help on this.

I have installed JCE WYSIWYG editor.

I am linking my article pages internally using the "link function" of the above editor.

I am successfully able to link sub-pages BUT not able to link the homepage from my articles.

When ever I insert the homepage contextual link in any of the article content, it displays change will hovering but does not link ahead.

I am totally unable to understand this problem?

2:57 pm on Sept 29, 2009 (gmt 0)

Moderator This Forum

WebmasterWorld Administrator ergophobe is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Apr 25, 2002
posts:8219
votes: 122


Are you entering it as an absolute link or a relative link? Have you tried both?
6:11 am on Sept 30, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:May 26, 2009
posts: 117
votes: 0


@ergophobe

When I try to insert a home page link in my articles by pasting the URL in the URL input box, it does not work.

However, if I choose the home page from the link browser-menu drop down list, it works!

What I am am confused is on 2 counts:

1. It is not accepting the SEF URL of the home page only (mysite.com), whereas it works fine with SEF URLs of sub-pages.

2. And, for the home-page URL: when a non-sef url (index.php?option=com_content&view=frontpage&Itemid=1) is entered, it works like a charm.

I also changed the SH404sef setting and skipped JCE in it's configuration but still it is not accepting the SEF URL of the home page.

Thanks.