Welcome to WebmasterWorld Guest from

Forum Moderators: httpwebwitch

Message Too Old, No Replies

XML works in Cooliris but only on some browsers. PLEASE HELP!

I added Cooliris to my web page but it only loads the XML sometimes.



5:48 pm on Oct 10, 2010 (gmt 0)

5+ Year Member

I followed the direction on the Cooliris site to add it to my web page. The problem is that the Cooliris swf always shows up, but the XML content its supposed to load only shows up in Firefox 3 and Safari 5 - not in Opera 10, IE 8, or Chrome 5. Is the problem in my XML file, or is it just not supported by some browsers? Cooliris says it supported by IE8. I don't get it.

Can anyone take a look and offer a suggestion?

[edited by: httpwebwitch at 7:12 am (utc) on Oct 11, 2010]
[edit reason] no self-promo links thankx [/edit]


7:30 am on Oct 11, 2010 (gmt 0)

WebmasterWorld Administrator httpwebwitch is a WebmasterWorld Top Contributor of All Time 10+ Year Member

The XML feed is syntactically perfect, well-formed & valid, so the XML isn't the problem.

That said, I tried it with Chrome 6.0 on a Mac and it worked OK. I don't have Chrome 5 installed so I couldn't test that.

The tough thing is if there's a problem happening in the SWF, you'd need to get the raw FLA in order to fiddle with the code and debug it. A precompiled SWF won't let you in like that.

My suggestion is to get a sniffer tool like FIDDLER (http://www.fiddler2.com/fiddler2/) - run it, and it will show you all the HTTP requests coming from your browser, including ones being issued by SWF. Start it up, then open your page in one of the bad browsers - see if the request is being sent, and look at the response if it is.

Featured Threads

Hot Threads This Week

Hot Threads This Month