Welcome to WebmasterWorld Guest from 54.234.38.8

Forum Moderators: httpwebwitch

Message Too Old, No Replies

XML parsing problem

My server machine refuses to load xml documents for parsing

     
10:35 am on Nov 16, 2006 (gmt 0)

New User

5+ Year Member

joined:Nov 16, 2006
posts:2
votes: 0


Hi everyone,

Have a problem that's really driving me bananas.

I have an intranet site that has a page that pulls rss feeds from different sources and displays them on an asp page.

Problem is i keep getting this error (from my error catching bit in the code):
-2146697208
The download of the specified resource has failed.
0
This feedback is generated from the following lines of code:
if addaxrss.ParseError.errorcode <> 0 then
Response.write addaxrss.ParseError.errorcode
Response.write "<br />" & addaxrss.ParseError.reason
Response.write "<br />" & addaxrss.ParseError.line
Response.write "<br />" & Server.HTMLEncode(addaxrss.ParseError.srctext)
end if

Now something really weird .... this code actually does display the rss feeds, however i've only seen the feed on the page twice, all other times, the code just comes up with the error.

Not really sure where the error lies, but I do know that the rss feeds are kosher (cnn, yahoo) and i have viewed them successfully using the same code .....

I'm really at a loss here, and need some divinely inspired intervention from someone out there....before I take a running jump out my office window.

Background info:
I've installed xml 3,4 & 6
running iis server on windows 2000 sp4
IE 6
I'ce checked the xml files and they seem to be well-formed

10:36 am on Nov 16, 2006 (gmt 0)

New User

5+ Year Member

joined:Nov 16, 2006
posts:2
votes: 0


Also, every single one of the feeds generates the same error, on the same line i.e. "The download of the specified resource has failed"
line number 0
4:54 pm on Nov 16, 2006 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Dec 17, 2001
posts:1262
votes: 0


Check that the paths you are requesting are accurate and that your asp has sufficient permissions.