Welcome to WebmasterWorld Guest from 54.145.53.251

Forum Moderators: bill

Message Too Old, No Replies

Test mode problem

     
12:46 am on Jan 26, 2010 (gmt 0)

Junior Member

5+ Year Member

joined:May 16, 2009
posts: 86
votes: 0


Hello,
I'm trying to enable test mode to load x64 unsigned drivers which worked before fine. I'm using Windows 7 x64.
Recently i made an hardware upgrade (i don't know if it has to with it) and since then i believe those drivers won't load anymore. Well not exactly, the thing that doesn't work anymore is disabling driver enforcement and test mode enabled from cmd.exe and some tools. I also made all the possible changes available on the Internet (registry, service)! BUT if I press F8 and disable driver enforcement at startup the drivers get loaded and work.
So why won't test mode start anymore? Do you know how to at least check if it's set ON?
2:03 am on Jan 26, 2010 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14478
votes: 49


I assume you're talking about test signing? If so that's set via BCDedit [msdn.microsoft.com].

To enable test-signing:

Bcdedit.exe -set TESTSIGNING ON

To disable test-signing:

Bcdedit.exe -set TESTSIGNING OFF
2:35 am on Jan 26, 2010 (gmt 0)

Junior Member

5+ Year Member

joined:May 16, 2009
posts:86
votes: 0


Yes that doesn't work at all, can i know if that is enabled?
4:21 am on Jan 26, 2010 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14478
votes: 49


Just run Bcdedit.exe and look for a line that says: "Testsigning Yes"
1:10 pm on Jan 26, 2010 (gmt 0)

Junior Member

5+ Year Member

joined:May 16, 2009
posts:86
votes: 0


It says Yes :( so how's possible that when I boot I get an error that the drivers can't be loaded cause of the missing signature. isn't testsigning supposed to let me load those drivers? It always worked. It also shows that loadoptions = DDISABLE_INTEGRITY_CHECKS!
BUT as I said if disable driver signature enforcement in f8 it works, I don't get it.
2:36 am on Jan 27, 2010 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14478
votes: 49


I agree that doesn't make much sense. You say this all worked before...before what exactly?
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members