Welcome to WebmasterWorld Guest from 54.144.206.73

Forum Moderators: lawman

WebmasterWorld header formatting messed-up

   
3:44 pm on Aug 3, 2009 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Not sure if this is the right place to post this.

I let Neil know yesterday that the formatting of the header for WebmasterWorld is messed-up in Firefox 3.5. It's fine in IE and Chrome. I'd appreciate it if someone would fix this already.

It seems to be a CSS positioning problem in that the logo is obscuring portions of the menu text.

I can't get to my Control Panel or make use of Search right now, both of which I use often.

I can provide a link to a screenshot of what I'm seeing upon request.

3:55 pm on Aug 3, 2009 (gmt 0)

10+ Year Member



I'm using FF 3.5.1 on XP Pro.

I only see the problem if I enable the NoScript add-on.

4:17 pm on Aug 3, 2009 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



You're right, Steve. I just disabled it and the header looks fine now even though I have WebmasterWorld whitelisted when it's enabled.

Any suggestions on a workaround anyone? I'd rather avoid having to restart my browser each time I visit here.

ADDED: The logo is being pulled from searchengineworld.com. I tried whitelisting it in NoScript but the problem persists.

8:04 pm on Aug 3, 2009 (gmt 0)

WebmasterWorld Senior Member swa66 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I see the overlap too since a few days, Thought I had something messed up with settings on my end (I did check the source code of WebmasterWorld, but saw nothing that would cause it in the time before I got distracted by real work).

I'm a big fan of Noscript, but it does it regardless of me allowign WebmasterWorld to run scripts or not.

FF 3.5.1 (mac)

11:07 pm on Aug 3, 2009 (gmt 0)

WebmasterWorld Senior Member swa66 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Thanks to the help of the author of NoScript, I now know it's a bug in NoScript, will be fixed in the next release (and they come often as all users of NoScript know).

From the developer notes over at noscript.net :


x Fixed invisible links detection turning some links into absolutely
positioned if they have no layout on load (thanks dpmccabe for
reporting)
11:29 pm on Aug 3, 2009 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



That's wonderful news. Thanks so much for looking into it. :)
5:17 pm on Aug 4, 2009 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



The NoScript update is available. I just installed it. Problem gone. Thanks again!
 

Featured Threads

Hot Threads This Week

Hot Threads This Month