Welcome to WebmasterWorld Guest from

Forum Moderators: phranque

Message Too Old, No Replies

Is Hosgator vulnerable to hacks? Is outdated scripts the real reason?

12:28 am on Feb 22, 2014 (gmt 0)

Preferred Member

10+ Year Member

joined:Dec 12, 2003
posts: 399
votes: 0

I have some very old Joomla sites on my hosting account and they keep getting hacked..

I suspect hostgator has got slack security and is blaming it on older CMS versions.

This is what they say:

"IMPORTANT: Failure to update these installations in a timely manner may result in suspension of the offending account until updates are applied."

Can they do that? Are they just making excuses because their servers and not secure?
12:58 am on Feb 22, 2014 (gmt 0)


WebmasterWorld Administrator phranque is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Aug 10, 2004
votes: 17

which version of joomla are you running?
joomla 1.7 reached the end of life a year ago, so if you are running unsupported software you are asking to be hacked.
7:05 pm on Feb 23, 2014 (gmt 0)

New User

joined:Feb 23, 2014
posts: 1
votes: 0

Any Web cms must have its own security layer because in order for a cms to function, normal Web server permissions must be set at less secure levels (e.g execute, read/write, on files and directories).
U also have scripting and mysql running behind the front end, providing easy access for sql injection attacks aimed at getting into your site. Hackers don't always need the server, your site will do fine thank u very much. ( e.g They can then use your site as a home base for all sorts of fun things they have planned for users who access it, etc)

U absolutely must keep content managements systems software updated. your host is not responsible for that