Welcome to WebmasterWorld Guest from 23.22.220.37

Forum Moderators: mademetop

Message Too Old, No Replies

Google Penalty on Homepage

penalty, seo

     
7:11 am on Nov 29, 2010 (gmt 0)

New User

5+ Year Member

joined:Jan 12, 2008
posts: 8
votes: 0


Hello,

it looks like google has a penalty on the homepage of one of my domains. I am running a portal on 3 domains (at/ch/com/). Since a few days the main page (.com) which goes for the german market is not on place one in the results if you look for the brand, instead the .at domain is number one. Even other pages from .com rank higher then the homepage. We had also a top position on a keyword that we lost now completly which was linking to the homepage. This is why I believe there is a penalty. What do you think?

A reasons could be a SEO programm we run. We give away a free item if a member links to his own site. The code also includes a link to the home page with just this keyword. Could this be the trouble maker?
Here is a link to a page that has our programm on:
[jobinfo.surfino.info ]
There are about 30 pages that used this code so far.

What should I do? Call all those admins to take the code down? Is this even the reason for the problem?

Thank you for any suggestion on this.

Merlin
10:19 am on Dec 3, 2010 (gmt 0)

Junior Member from IN 

10+ Year Member

joined:Nov 3, 2002
posts: 91
votes: 0


Google's webmaster tools may help shed more information

[google.com...]
10:57 am on Dec 3, 2010 (gmt 0)

New User

5+ Year Member

joined:Nov 26, 2010
posts:3
votes: 0

@chrisranjana is right. This might even happen because of malicious code on the webpage. Check website's Google Webmaster Console.
11:00 am on Dec 3, 2010 (gmt 0)

New User

5+ Year Member

joined:Jan 12, 2008
posts: 8
votes: 0


thanks guys. problem has been solved.
3:47 pm on Dec 3, 2010 (gmt 0)

Senior Member

WebmasterWorld Senior Member g1smd is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:July 3, 2002
posts:18903
votes: 0


What was the issue, and how was it solved?