Welcome to WebmasterWorld Guest from 54.167.46.29

Forum Moderators: open

Message Too Old, No Replies

Opera 10 scroll oddity

     
8:48 am on Jul 2, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts: 14487
votes: 49


Any other Opera 10 beta testers out there? I'm noticing an odd behavior with the scrolling of long pages particularly here on WebmasterWorld.

When reading a long thread and then backing out to the forum listing I notice that the forum listing has scrolled an equivalent length down the page. This is bad. Opera 10 is not remembering the previous pages' position. It's enough of a problem that I'm thinking of moving back to Opera 9.

Anyone else experiencing anything like this?

1:16 am on July 6, 2009 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Nov 12, 2002
posts:1482
votes: 0


Do you have an example WebmasterWorld URL to test?
1:52 am on July 6, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


I just uninstalled Opera 10 as this was becoming a productivity issue for me.

Take any long WebmasterWorld thread. Open it. Scroll to the bottom. Then use your back button.
The thread list on the previous page would be scrolled down.

11:11 am on July 7, 2009 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Nov 12, 2002
posts:1482
votes: 0


Hmm, I can't reproduce this... anyone else? I used both my back button and mouse gesture.

The page I used was: [webmasterworld.com...] and I'm showing 20 messages per page.

4:20 am on July 8, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


I have my Messages per thread at 50 (max) and Max threads on forum list at 100 (max). I wonder if that was a factor?
10:30 am on July 20, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:Nov 16, 2006
posts:64
votes: 0


How do you go back to the forum listing? If you use the Back button, it should go back to the previous position.
4:24 am on July 21, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


How do you go back to the forum listing?
Mouse gesture, back button on the mouse, or back button on the browser all had the same results.
8:48 am on July 21, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:Nov 16, 2006
posts:64
votes: 0


Yes, so you do not return to the same position on the previous page as you were at before you went forward?
5:01 am on July 22, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


Correct.
That's a major problem for someone who spends a lot of time in forums like this.
9:56 am on July 23, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:Nov 16, 2006
posts:64
votes: 0


I just had a chat with the dev who's into this and he says it sounds like a bug. Please file it at [bugs.opera.com...] and post the bug number here and I'll make sure it gets some attention. Thanks.
2:08 am on July 24, 2009 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


Thanks Mitchman. I filed the bug:DSK-259734
I hope I explained it well enough. It's a difficult one to describe.
2:29 pm on July 24, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:Nov 16, 2006
posts:64
votes: 0


Thanks. I tried to reproduce and so did QA without success. Could you try with a clean profile please?