Welcome to WebmasterWorld Guest from 54.162.239.134

Forum Moderators: brotherhood of lan & mack

Message Too Old, No Replies

php email problem

email problem

     
5:03 am on Sep 1, 2009 (gmt 0)

5+ Year Member



Hi there.

I have a problem with the php email form i have included in my system. Basically, what it does is send an email to a person (personA) when an action is satisfied (that is, related to the request of personA)... It's like a confirmation email.

What I did was, when I tested it, I tried to send an email to our local email (myname@locdom.gov.xz)... So, when I Submitted the form, I got the email - fine. However, when I try to test it by sending an email to another user on our domain (e.g. hisname@@locdom.gov.xz), the person does NOT receive the email supposedly generated by the script. May I know what I should further do? I am using an xampp installation, and have set the variables in my php.ini file to:
SMTP = [valid IP of our mailbox Exchange Server]
smtp_port = 25

I hope you can help me with this problem.

Thanks in advance!

5:05 am on Sep 1, 2009 (gmt 0)

5+ Year Member



Errr... I should have said
when I tested it, I tried to send an email to our local email (myname@locdom.gov.xz)...
to:
when I tested it, I tried to send an email to my local email (myname@locdom.gov.xz)...

Sorry...

4:46 am on Sep 8, 2009 (gmt 0)

5+ Year Member



uh, guys, any ideas?
thanks!
6:30 am on Sep 8, 2009 (gmt 0)

WebmasterWorld Administrator brotherhood_of_lan is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



Hello blackheartnaz,

Do you have SSH access? It's worth just testing the PHP mail function on its own and seeing what it says. The problem may or may not be PHP related.

Try something like this in an example script and see who all gets the e-mail


mail('you@example.com', 'Test','Test message');
mail('someoneelse1@example.com', 'Test','Test message');
mail('someoneelse2@example.com', 'Test','Test message');

further reference [uk.php.net] in the manual.

2:28 am on Oct 5, 2009 (gmt 0)

5+ Year Member



thanks, brotherhood...
i'll try it...
1:38 am on Oct 26, 2009 (gmt 0)

5+ Year Member



hi....

i have a new problem regarding this email thing.
the system i was developing was migrated to a Linux-based server. and now, the email notification does NOT work, unlike when i am running the system on XAMPP environment...

what can I do to address the problem?

my LAMP phpinfo shows:
standard
Regex Library - Bundled library enabled
Dynamic Library Support - enabled
Internal Sendmail Support for Windows - enabled

my XAMPP phpinfo shows:
standard
Dynamic Library Support enabled
Path to sendmail /usr/sbin/sendmail -t -i

likewise, LAMP shows:
sendmail_from - helpdesk@#*$!x helpdesk@#*$!x
sendmail_path - /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i

while XAMPP shows:
sendmail_from - helpdesk@#*$!x helpdesk@#*$!x
sendmail_path - no value no value

i have asked the tech guy to set
SMTP and smtp_port to what is set on my XAMPP environment,
hoping it will solve the problem, but still no go....

help please.... thanks!

 

Featured Threads

Hot Threads This Week

Hot Threads This Month