Welcome to WebmasterWorld Guest from 54.144.243.34

Forum Moderators: ocean10000

Any advice for deploying web services using WCF / .NET 3.5 ? (IIS v6)

web services deployment problems (WCF/ .NET v3.5)

   
5:18 pm on Oct 4, 2010 (gmt 0)

5+ Year Member



Hi

We have had trouble deploying our web services using WCF / .NET v3.5 on IIS v6.

We are developing web services using RESTful/JSON and although it works nicely locally, we cant get it to deploy correctgly.

Further details:

- WCF (Window Communication Foundation)
- .NET v3.5
- Windows Server 2003,
- IIS v6

Have any of you guys some something similar?

John
6:06 pm on Oct 4, 2010 (gmt 0)

WebmasterWorld Administrator 10+ Year Member Top Contributors Of The Month



Question is the website set to use .Net 3.5 and not 2.0 this can cause some problems, and is easy to lookover when setting up the production server.
6:24 pm on Oct 4, 2010 (gmt 0)

5+ Year Member



Thanks - I'll find out.
Btw, do you know where exactly is this set?
(.NET has definitely been installed on the machine...)

John
9:45 pm on Oct 4, 2010 (gmt 0)

WebmasterWorld Administrator 10+ Year Member Top Contributors Of The Month



Open IIS Manager. In navigation pane, find the .NET web site and right click on it. Select "Properties". Then select "ASP.NET" tab. First dropdown on that screen gives you option to select a different version of .NET.
7:11 am on Oct 5, 2010 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



First dropdown on that screen gives you option to select a different version of .NET.

But, even if you have 3.5 installed you won't see it in this dropdown as 3.5 is basically 2.0 with a few extra libraries.

I usually check the following folders to see what is installed on the server:
C:\Windows\Microsoft.NET\Framework\
C:\Windows\Microsoft.NET\Framework64\
 

Featured Threads

My Threads

Hot Threads This Week

Hot Threads This Month