Welcome to WebmasterWorld Guest from 100.24.209.47

Forum Moderators: martinibuster

Message Too Old, No Replies

Ads on website search pages seem to have lower coverage

If specific query strings haven't been crawled?

     
9:38 am on Apr 25, 2018 (gmt 0)

Senior Member from GB 

WebmasterWorld Senior Member 10+ Year Member Top Contributors Of The Month

joined:July 17, 2003
posts: 717
votes: 27


This just occurred to me. On some of my sites I use a facets based search setup so users can drill down to find what they are looking for.

There are 2 issues here; firstly the querystring combinations can be fairly unique and secondly the facets are nofollow / noindex.

I'm seeing quite a few blank ad spaces when looking at these pages and am thinking this may be related to the "Brand Safety" issue.

One thing I was thinking of was editing the URL parameters in Webmaster search console to "Does not effect content". The other is changing the facet links to not be nofollow (which I'd rather not)

Any ideas?
10:15 am on Apr 25, 2018 (gmt 0)

Preferred Member

Top Contributors Of The Month

joined:Mar 25, 2018
posts:500
votes: 101


Yes, this is certainly due to the "Brand-Safety". Adsense's bot has to fetch a page, before ads are shown. This kind of page keeps getting new, and unknown by Adsense at first.

NickMNS explains it well here :
[webmasterworld.com...]
10:29 am on Apr 25, 2018 (gmt 0)

Full Member

5+ Year Member

joined:Aug 16, 2010
posts:257
votes: 21


Try to rewrite your GET parameters to POST. For me this solved the problem of blank ad spaces.

In my experience it has nothing to do with NOINDEX/NOFOLLOW, i have lot of pages with it and ads are showing perfectly. As long as the page gets crawled every few weeks.
10:41 am on Apr 25, 2018 (gmt 0)

Senior Member from GB 

WebmasterWorld Senior Member 10+ Year Member Top Contributors Of The Month

joined:July 17, 2003
posts: 717
votes: 27


@bhukkel thanks for the suggestion but this is using the Drupal facets API which is so mind-numbingly complex that I don't think this is an option.

@Travis - that's quite a thread! Will have a good read through it. I overlooked it because coverage has not been an issue for me. Always around 75-80% (inline with ad balance - if that limits it?)

What I have noticed is there are blank ads (as mentioned) with no backup shown. Also, there are often a mix of filled and unfilled ads on the page - so how does "Brand Safety" sit with that?
10:44 am on Apr 25, 2018 (gmt 0)

Senior Member from GB 

WebmasterWorld Senior Member 10+ Year Member Top Contributors Of The Month

joined:July 17, 2003
posts: 717
votes: 27


Does anybody know if setting the URL parameters in the Search Console has any effect on Adsense / mediabot - assuming the accounts are linked?