Welcome to WebmasterWorld Guest from 100.26.182.28

Forum Moderators: martinibuster

Message Too Old, No Replies

So many ads not loading nowadays?

     
9:30 pm on Feb 23, 2017 (gmt 0)

Junior Member

Top Contributors Of The Month

joined:Nov 29, 2015
posts:112
votes: 32


Is anyone else seeing this?

I'm constantly seeing the shape of an ad - but then just a page cannot be displayed page within that shape. Or just a blank space.

It seems to happen too often to just block the ad.

And sometimes - when you right click to refresh - it appears as one of the usual ads that show on your site.

Just seems annoying how many possible clicks I could be missing! ;)
10:05 pm on Feb 23, 2017 (gmt 0)

Senior Member

WebmasterWorld Senior Member Top Contributors Of The Month

joined:Nov 13, 2016
posts: 1194
votes: 284


You can open the developer tools of your web browser, and observe what is being output in the console, there might be some kind of error messages, or things explaining what you are experiencing.
3:50 am on Feb 24, 2017 (gmt 0)

Full Member

5+ Year Member Top Contributors Of The Month

joined:Aug 14, 2014
posts:320
votes: 99


I see this happening too (in Chrome) lately but a quick test in Firefox (with search history turned off) or Edge and everything appears to be working normally.

I never gave it much though.
4:26 am on Feb 24, 2017 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member keyplyr is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Sept 26, 2001
posts:12913
votes: 893


leebow are you using the Ad balance slider?
8:20 am on Feb 25, 2017 (gmt 0)

Junior Member

Top Contributors Of The Month

joined:Nov 29, 2015
posts:112
votes: 32


I don't use the ad balance bar - I think google should be making their ads more attractive to people - not hiding them because they know X% of them people won't click them.

A LOT of my ads produce errors in browser console - but its random - and like I say - sometimes an ad will load fine, then the very same ad on another page might produce a "cannot be found" error page.

It's not "loads" of ad requests - but it's enough to be noticble.
8:59 am on Feb 25, 2017 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member keyplyr is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Sept 26, 2001
posts:12913
votes: 893


Missing ads have been discussed a couple times. As CommandDork said, sometimes the same ad will display if viewed on a different browser.

No definitive answer why ads may not be loading, but a couple possibilities:

Missing ads could be caused by internet congestion between Google's ad server & your server.

Missing ads could be caused by low ad inventory for your matching content.

If you're still using nonsecure pages (HTTP) many ad publishers may only be creating secure (HTTPS) ads.
12:30 pm on Feb 25, 2017 (gmt 0)

Moderator

WebmasterWorld Administrator buckworks is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Dec 9, 2001
posts:5834
votes: 159


Something else I wonder about: If an ad image is poorly compressed and the file is way bigger than it needs to be, might that affect ad loading?

Poorly optimized ad images are a common complaint when I check pages with Page Speed, so I wonder if that might be part of the mix.
12:36 pm on Feb 25, 2017 (gmt 0)

Senior Member

WebmasterWorld Senior Member Top Contributors Of The Month

joined:Nov 13, 2016
posts: 1194
votes: 284


>> If you're still using nonsecure pages (HTTP) many ad publishers may only be creating secure (HTTPS) ads. <<

HTTPS ads are displayed well on non HTTPS pages. That's the opposite which is a problem.

leebow points something I mentioned in other topics, the fact that since mid January, I see error message in the console window, related to Adsense ads. I don't know how they are impacting or not the display / counting . (I mean, errors, not warnings).
5:03 pm on Feb 25, 2017 (gmt 0)

Junior Member

Top Contributors Of The Month

joined:Nov 29, 2015
posts:112
votes: 32


Exactly - I blame html5/JavaScript for the problem - and the reliance on so many libraries.

When ads were just a single flash swf file - it just worked. A 40kb ad could contain everything it needed - images, animation, etc.

Now - with JavaScript ads - they have so many external libraries for animation, and uncompressed images - they are slow to load, buggy and produce some strange errors in the browser console.

I'm thinking of trying only image ads to see if that reduces the problem. But like I said - because it's not very often - it would be hard to monitor if it's helping.
5:04 pm on Feb 25, 2017 (gmt 0)

Full Member

10+ Year Member

joined:May 25, 2006
posts:300
votes: 36


I have seen this quite a lot recently, and did wonder if it was ad slider related, but when I refresh the page quality / relevant ads usually appear so they are available.
Overall adsense doesn't seem to be down: rpm is down slightly c. 5% for the last 14 days but probably not statistically significant amount, could be due to non displaying ads but could be exchange rate differences etc, advertiser availability etc
5:47 pm on Feb 28, 2017 (gmt 0)

Full Member

5+ Year Member Top Contributors Of The Month

joined:Aug 14, 2014
posts:320
votes: 99


Today I'm seeing a lot of non-loading ads - across all browsers and OSs. Slider is 100% / 85% so maybe it's inventory for my industry. But still, a little weird.

The AdChoices button loads like normal but the adblock itself stays blank. Doesn't appear that the backup ads are running either.
4:44 am on Mar 1, 2017 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member 5+ Year Member Top Contributors Of The Month

joined:June 6, 2010
posts:764
votes: 109


Same here last two days active view has dropped by 10%
6:00 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


I am having the same problem.... You guys are not the only ones... Some pages will show 1 ad... some will show 2... some will show all 3... some will show none...

When this is occurring all I see is irrelevant ads...

Site is a high traffic site that generates between 400k-700k page views daily.
CTR is down 90% & CPC is down 40%
Would estimate the loss to be around 10k

I will give them until the end of the month to fix the issue or will be switching
6:03 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


This has been going on since feb 21st for my site...
6:12 pm on Mar 1, 2017 (gmt 0)

Moderator This Forum from US 

WebmasterWorld Administrator martinibuster is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Apr 13, 2002
posts:14923
votes: 492


You said it happens more in one browser over another. Could it be your browser? I just deleted nearly 400mb of files from a browser cache, over 6,000 files. When was the last time you cleaned out your browser?

Could your hosting be getting in the way?

Are there many scripts and fonts loading up?
6:52 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


It comes and goes with all browsers I have personally tested. Firefox, IE, Chrome and Safari
6:55 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


I also have noticed a considerable lag on mobile responsive ads being displayed. 2-4 seconds on some to the point where the user will already pass the ad before it actually loads. Ad viewable has gone from 70% to 35% with my site.

I run on my site on a dedicated server
7:50 pm on Mar 1, 2017 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member keyplyr is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Sept 26, 2001
posts:12913
votes: 893


Hi itek and welcome to WebmasterWorld [webmasterworld.com]
8:32 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


Thanks keyplyr
8:34 pm on Mar 1, 2017 (gmt 0)

New User

joined:Feb 27, 2017
posts:16
votes: 3


I have also noticed that when I head to DEVELOP Empty Cache ALL ads will show but when I go to the next page all ads will disappear. This appears to be a browser caching issue in my opinion.
10:48 pm on Mar 1, 2017 (gmt 0)

Moderator

WebmasterWorld Administrator buckworks is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Dec 9, 2001
posts:5834
votes: 159


I was reviewing ads in the AdSense ad reviewer and some of the ads were painfully slow to load in there, too.

So it's not just our sites.
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members