Welcome to WebmasterWorld Guest from 3.80.38.5

Forum Moderators: Robert Charlton & goodroi

GSC links reported on another site are to my domain but they are not

     
4:53 pm on Aug 22, 2018 (gmt 0)

Junior Member

Top Contributors Of The Month

joined:June 28, 2018
posts: 130
votes: 25


In Google Search Console I saw that there is a site that is being reported as linking lots of times (100s) to my site and that site is a non related site so I investigated in case it was a candidate for disavowing (it is a e cigerette / vaping site and my site is travel related). I found something very strange though.

The "linking" site (lets call it LINKSITE) and my site both use the same theme and also have turned on the same extended-reviews extension that comes with the theme. Somehow this is causing google to see that each LINKSITEs review pages are somehow linking to my review comments pages , but I cannot see how they are in any way and dont believe this is the case. Its confusing to explain but will try with some examples:

IN GSC it list LINKSITE under the Top Linking Sites section, I drill down one level and get a list of all of my pages under the Top Target Pages section that LINKSITE supposedly links to and all of these urls are of type mysite.com/extended-reviews/product_comment/add/id/**/ where ** is an id number.

I click and drill down further into one of these Top Target Pages and I get the list of Linking Page / Target URL - this is where it gets strange. Every single link reported is in the form of : Linking Page = LINKSITE.com/category/productname Target UR= LINKSITE.com//extended-reviews/product_comment/add/id/**/ and is NOT linked to MYSITE at all.

Checking the source code of the Linking Page on LINKSITE , does not show any link to my site at all and going to the reported Target URL on LINKSITE every page go to a very basic comment form that is not displayed in a form meant for human visitors and is like :
{"content":"
\n
Post a comment<\/h6>\n
\n
\n
\n *<\/em>Nickname<\/label>\n
\n
\"\"
\n <\/div>\n <\/li>\n
\n *<\/em>Comment<\/label>\n
\n

The source code of this is again not showing any links to my site at all.


So as far as I can see there is no actual links between LINKSITE and mysite yet google is somehow seeing that there are because of us using the same theme and have the same reviews extension that creates the same url structure for comment submits.

Im completely lost as to why this would be and the only action I can thin of is to disavow the site but if google can mess up like this then Im scared that it will mess up again and some how disavow my site from my self or something crazy like that!
3:32 am on Aug 23, 2018 (gmt 0)

New User from IT 

joined:Aug 2, 2018
posts:9
votes: 2


I think you should not worry that much: it happens to me quite often, that I see reported domains linking my site in GSC but they are not actually linking. Moreover, differently from the past now it has been quite a time that Google says to use the disavow tool only if you have received a penalty or if you think that those sites are hurting your ranking. Furthermore, since there is no real link pointing to your site, you should run even less risks. It might be just a bug, I mean just a "visual one" that you see that report, but probably Google won't see any link anyway and so there shouldn't be any problem.
5:14 am on Aug 23, 2018 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member keyplyr is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Sept 26, 2001
posts:12913
votes: 891


I agree with everything Andrew78 has said.
1:53 pm on Aug 23, 2018 (gmt 0)

Senior Member

WebmasterWorld Senior Member aristotle is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Aug 4, 2008
posts:3524
votes: 324


I've been seeing this for years in my GSC reports. My theory is that these are auto-generated spam links that did exist for a short time, but were soon removed. But googlebot happened to crawl during the short time that they existed and saw them then.

So by my theory, the links did exist for a short time. But by the time you see the GSC report, they've been removed and no longer exist.
9:16 pm on Aug 23, 2018 (gmt 0)

Senior Member

WebmasterWorld Senior Member aristotle is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Aug 4, 2008
posts:3524
votes: 324


Now it occurs to me that it intentionally waits for googlebot to crawl before deleting these links on the other site. This ensures that they appear in your GSC report. If you see these links in GSC, and go to the other site to investigate, you've been lured to the other site as a visitor. So it's a sneaky way to get "traffic" to a site. Similar to referral spam.
11:57 pm on Aug 27, 2018 (gmt 0)

Junior Member

Top Contributors Of The Month

joined:June 28, 2018
posts: 130
votes: 25


thanks guys - been a bit crazy last few days so not been on the forum (had a site disaster that I had to work on and recover but all good now - some lessons learned!)

You all may be correct - I have today disavowed the domain anyway as as its not related to me and I cant see I was getting any value at all. I dont think it was something done on purpose by the site - they seem quite legit and I think its too much of a coincidence that we both use the exact same theme which is causing the same url patch to be created - it seems like a google glitch to me but I guess we will never know for sure.
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members