Welcome to WebmasterWorld Guest from 54.221.49.52

Forum Moderators: incrediBILL & lawman

Message Too Old, No Replies

Just blew an hour on "submit url"

Arrrghhhh!

     

Liane

1:57 pm on Dec 2, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Man oh man ... what a waste of time!

[Beginning of rant]

I found what I thought was a really great site to get listed at. It had a very "in depth" site submit procedure which required a good deal of reading, finding your "exact" category to submit to, providing a link to them in exchange (code and all), writing an article for them to include in their "country specific directory", etc. etc.

Upon submitting the form, I got an error 404!

Now, when a site makes you jump through hoops to get a link, I expect them to at least have the good manners to keep their site working properly. On top of that, there isn't even any contact information in order to contact them dirtectly or the webmaster.

They have a PR7 and a pretty zippy site. I thought I had found a really good resource. All I did was waste an hour of my life. *&^%$#@ *&^%$

[End of rant]

jackofalltrades

2:02 pm on Dec 2, 2002 (gmt 0)



lol :)

Thats why i just have a nice wee email link on my submit URL page!

Have you tried sending an email to webmaster@thesite.com, or info@...?

JOAT

ps attach a copy of your post to the email! ;)

Liane

2:14 pm on Dec 2, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



No, I haven't tried that but will. I don't think I'll include a copy of my post though, it may not go down too well. :)

Seriously though, I am really picky about where I submit my site and I was really upset that my submission didn't go through. Considering how picky they are about which sites they will accept ... one would think they would ensure that their site is maintained to the same professional level they expect from submitters!

(I have never had to do so many cartwheels in my life to submit my site).

 

Featured Threads

Hot Threads This Week

Hot Threads This Month