Welcome to WebmasterWorld Guest from

Forum Moderators: open

Message Too Old, No Replies

Google Toolbar Disappeared?




3:59 pm on Mar 30, 2002 (gmt 0)

My google toolbar has disappeared. I checked the google toolbar FAQ. They suggested to check View/Toolbars/ make sure google toolbar is checked. Google toolbar no longer appears in View/Toolbars. I've tried to reinstall the google toolbar. Downloaded it again, etc., but when I try to install it I get the message that I don't have a file required to install the toolbar...Windows\system\GoogleNav0.dll...but I looked for this file and it is actually there.

I am using Windows 98, Internet Explorer 6.

I have recently installed Norton Internet Security
and Ad-Aware. I don't know if these installations may have affected anything.

I'd appreciate any help anyone might be able to give me. Thanks in advance:)


5:59 pm on Mar 30, 2002 (gmt 0)

10+ Year Member

I would start by going to Add / Remove programs in the control panel and remove the Google Install from there. Reboot and try to reinstall the Google toolbar.

After that I would say it is registry cleanup time.

Hope this helps.


6:08 pm on Mar 30, 2002 (gmt 0)

WebmasterWorld Senior Member marcia is a WebmasterWorld Top Contributor of All Time 10+ Year Member

When I had a problem uninstalling and reinstalling the toolbar I didn't have to go near the registry. I ended up uninstalling the toolbar, closing all IE windows, clearing all cookies as someone here suggested, rebooting the computer, and then reinstalling the toolbar. It worked and has been fine since with no problems.


9:45 pm on Mar 30, 2002 (gmt 0)

10+ Year Member

The registry is still more fun. =)


11:37 pm on Mar 30, 2002 (gmt 0)

Thanks for your replies. I have tried uninstalling and then reinstalling. I get the same message when I try to install the toolbar.."one of the library files needed to run this application cannot be found. c:\windows\system\GoogleNav0.dll".

When I check c:\windows\system, the file appears to be there.

The only thing I tried with the registry is to run regclean and windows registry checker. After this I haven't a clue about the registry.

I also tried removing all cookies and this didn't work.

Does anyone know if Ad-Aware or Norton Internet Security could have messed me up? This happened after installation of these programs.

I want my TOOLBAR back!! :(


3:39 am on Mar 31, 2002 (gmt 0)

10+ Year Member

Now this is just what I would do...

Thus it being Windows 98 I would do a start, shutdown, and restart in MS Dos mode.

From there do:

C:\>scanreg /restore

Pick a day or 2 before the toolbar stopped working and restore.

Be aware you will lose some software registry settings. ie: Norton Internet Security and Ad-Aware.

I would then rename the windows\system\googlenav0.dll to a .old or something and then try to reinstall the Google bar.

That I would think should do the trick. Or at least get us more info.

Hope this helps.


5:22 am on Mar 31, 2002 (gmt 0)

Thank you JBoss008.

I did what you recommended.

I did a start, shutdown, and restart in MS Dos mode.

From there:
C:\>scanreg /restore

I picked a day or 2 before the toolbar stopped working and restored.

I renamed the windows\system\googlenav0.dll to .old

I didn't even need to reinstall the toolbar. When I opened my browser it was there.

I then tried to uninstall Norton Internet Security. It would not uninstall because it said the program was not on my system. Then I went to install Norton Internet Security from the cd. I got to the process where it detected the 2001 version of Norton Antivirus on my pc and said it would uninstall this version before installing the 2002 version. Then I had to reboot my system. After the reboot, I opened Internet Explorer and the Google Toolbar was gone again. I didn't continue with the Norton installation, because I didn't know what was causing this problem. Any ideas? What should I do now????


12:38 pm on Mar 31, 2002 (gmt 0)

10+ Year Member

Boy I hope I am not getting you in to deep here. Definatly sounds more like a registry thing now.

Now once again this is only what I would do...hopefully this helps.

C:\>scanreg /restore

Restore from yesterday. Once you have restored when you go into the add / remove programs, Norton Internet Security and Ad-Aware should both be in there. Lets try and uninstall Norton, reboot, and then check your Google bar to see if it is back. If you are back then I would say Norton Internet Security is loading something up that is killing the bar. I don't think it is Norton Anti-Virus as I run this all on all my computers / clients and the Google bar works fine.

If that doesn't work lets see if we can figure it out for you.

Good Luck.


1:36 pm on Mar 31, 2002 (gmt 0)

I did the above. Restored from yesterday. Uninstalled Norton Internet Security. Google toolbar was not there. Tried to reinstall Google Toolbar and got the same message about the GoogleNav0.dll

Now what. I'd like to have the toolbar and be able to use the Norton stuff. Very strange.



2:52 am on Apr 1, 2002 (gmt 0)


It sounds like you may have a static vxd hanging around that is causing your problem.

I would try and run msconfig and take a look at what you have starting up when the computer boots. Try and remove all the check marks except for system tray and see if this clears some or all of your problems.

If you can run your google bar with all these things unchecked then you know that you have a problem with something in your startup.

I hope this gets you pointed in the right direction.


6:32 am on Apr 1, 2002 (gmt 0)

im having the exact same problem cat. cept im running winme and ie6. if i go to tools/options then temporary internet files/settings/ then view objects, i get a wierd file number that says it (the toolbar control ) is there but not installed. (duh) checking its properties it says its dependent on a file called googlenav.dll
(i cant find it ). although googlenav0.dll is in the system directory. i also get that same missing googlenav0.dll error when using the manual installer exe. ive tried going through the registry an deleting everything google and deleting the nav0 dll but it still wont install. oh yeah, i tried that selective startup with msconfig and when my machine didnt bluescreen it made no difference what vxd loaded. it still wouldnt install. dammnit.

Peanut Butter

9:52 pm on Apr 1, 2002 (gmt 0)

There's an .exe version of the Google Toolbar installer that might work better than the usual ActiveX installer. Did you try that?


1:00 am on Apr 2, 2002 (gmt 0)

I ran msconfig and removed all the start up check marks except for system tray and still couldn't install the google toolbar. The only thing I couldn't stop from loading this way was iamapp.exe which has something to do with Norton Internet Security.

I also tried the .exe version of Google Toolbar installation and couldn't install.

I still get the same message about the GoogleNav0.dll.


3:14 pm on Apr 2, 2002 (gmt 0)

10+ Year Member

littlefat, this is a long shot: is there a file named "tinybar.html" anywhere on your hard drive (first look in C:\WINDOWS\SYSTEM)?


3:21 pm on Apr 2, 2002 (gmt 0)


No tinybar


5:34 pm on Apr 2, 2002 (gmt 0)

10+ Year Member

I renamed the windows\system\googlenav0.dll to .old

I didn't even need to reinstall the toolbar. When I opened my browser it was there.

Am I the only one seeing this... try renaming the .dll file back to it's original name and rebooting, or, finish the last step that was suggested (re-installing the google bar).


5:53 pm on Apr 2, 2002 (gmt 0)

Tried both, Dan

Didn't work


4:37 am on Apr 3, 2002 (gmt 0)

got bored/annoyed and reinstalled windoze earlier. it dropped me back to ie 5.5. i had to re download the flash player plugin from macromedia website - installed fine thru the applet. had to download a control from windows update to access the update site and it installed fine too. tried to do the google toolbar thing and nope. straight after clicking yes on the "do you wish to dl and run the applet " i get the installed failed screen. so i can dl and install stuff off of other sites just not googles control.
tried the installer exe again to see if it would go under ie 5.5 nope. still get dumbass googlenav0.dll file missing even tho its there. actually ive found if you delete the googlenav0.dll file and run the exe installer it puts it back. funny that, cause it then says its not there, straight after it installed it itself.!!. and yes i did try it again after that as well. just in case.
im not going to give up. that toolbar was just too damn cool.


10:02 am on Apr 3, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

Try looking for ezsearch.dll

Bad news if you find it


10:05 am on Apr 3, 2002 (gmt 0)


I've deleted the googlenav0.dll file too, and noticed that the installer puts it back. Then I get the message that it's not there.

I've sent this discussion to GOOGLE TOOLBAR, "how to report a problem". Hopefully there's a real person there who'll respond to this issue.


10:09 am on Apr 3, 2002 (gmt 0)

No ezsearch.dll, Troll


3:28 pm on Apr 3, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

Fair 'nuff. I had a similar problem to the one you describe with that little puppy recently, but it seems you have found an entirely new way to break the toolbar. Congrats :)


3:29 am on Apr 4, 2002 (gmt 0)

I noticed that when I installed Norton Antivirus 2002, that a Norton Antivirus Toolbar was installed on Internet Explorer 6.
Does anyone know how I might be able to tell if the Norton Toolbar is overriding the Google Toolbar somehow?? When I installed Norton Antivirus 2002 is when I started having problems with the Google Toolbar!!


5:26 am on Apr 4, 2002 (gmt 0)

i noticed sumthing similar but.... ive just uninstalled nav2002 and tried again still no good. so its still broke wether nav is there or not. obviously when nav goes its toolbar goes with it. (yes i checked). i went sniffing around the microsoft knowledge base for reasons on why the active x installer was dying but it wasnt very helpful. one thing i did try was deleting the downloaded programs folder where the controls live. just in case there was a corrupt file lurking there. didnt do nuthing. cept i had to redownload all the other damn controls again. which also reinforced the fact that i can dl other stuff just not the google one.
can anyone give me a list of all the registry keys so i can go thru and delete them. i must have missed sumthng earlier when i tried. cheers .


5:44 am on Apr 4, 2002 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

This is a long shot but what do you have to lose.

Place a copy of GoogleNav0.dll into c:\Windows\system32\ and see if that has any effect.


7:34 am on Apr 4, 2002 (gmt 0)

ive done it. its a corrupt index.dat file.

go here [content.techweb.com...]

1. read article.
2. download javascript.
3.when nav goes mental about a malicious script clik on the drop down menu and select the allow/authorise script option so it wont keep bugging you.
4.when its done reboot if it doesnt do it for you.
5.nasty corrupted index.dat file purged.
6.load up explorer.
7.go to your favorite search engine.
8.install the online script.
9.bask in the glory that is your newly restored google toolbar.
10. apoligise to google for ever doubting in their fine product.


7:54 am on Apr 4, 2002 (gmt 0)

oh yeah. in my extreme elation of having restored my toolbar, i forgot to thank everyone who chipped in with suggestions and ideas for this. it all helped. thanx to you all.
btw. in case the above fails for whatever reason before i purged the index.dat file i did go to tools/options and clicked on delete files. then delete cookies. ticked also the offline content box as well. i also had removed the earlier bad? googlenav0.dll
and removed the status (unknown) control (big long clsid number/key) in the box that pops up when you clik tools/options/settings/view objects. so my machine was pretty damn clean.

maybe this solution could be edited and put in the google toolbar faq? under corrupt index.dat file can prevent install hmmm?.
that would be cool. ;) ;) ;) ;) ;)


1:22 am on Apr 5, 2002 (gmt 0)

W:)W, Simm, you've done it!!! How you figured it out is beyond me, but I've got my toolbar back!!
Thanks for your tenacity!!

I'm sending these posts to the G:):)GLE people!!

Thanks again!!


4:07 am on Aug 13, 2002 (gmt 0)

10+ Year Member

My Google toolbar is not showing the PageRank info (it was last week). No-one else in our office has this problem, so it's obviously my PC.

I've uninstalled the toolbar, rebooted, reinstalled the toolbar. No joy.

Can anyone help?


11:48 am on Aug 13, 2002 (gmt 0)

WebmasterWorld Senior Member ciml is a WebmasterWorld Top Contributor of All Time 10+ Year Member

feeder, I take it that PageRank display is checked, in "Advanced features" of the Toolbar Options?
This 31 message thread spans 2 pages: 31

Featured Threads

Hot Threads This Week

Hot Threads This Month