Welcome to WebmasterWorld Guest from

Forum Moderators: bakedjake

Message Too Old, No Replies

Mandrake Versus Redhat



5:55 pm on Jun 19, 2002 (gmt 0)

10+ Year Member

I have been frustrated with the slow down of my machines since upgrading to Redhat 7.3. The systems just feel stuffed up.

So I bought a new machine, did alittle research on the hardware and ended up with a asus board with the Intel 845-e chipset on board 6 channel sound and lan. Installed 7.3 and it found the sound lan and agp but fails with the ide controler. System runs slow. Last night I installed ver 7.2 and this box is ALOT faster.

The running kernel is 2.4.9-34with version 7.2 and 2.4.18-4 with 7.3. Now the kernel specs with 2.4.18-4 look like they should be better. So what I am tring to decide is if its the redhat installer or if its the kernel.

Any Ideas ?
Is Mandrake better and why ?
Mandrake 8.2 comes with the 2.18 kernel is there a chance that it would run better?



4:43 am on Jun 20, 2002 (gmt 0)

WebmasterWorld Senior Member littleman is a WebmasterWorld Top Contributor of All Time 10+ Year Member

What about background services, daemons?
When you ps -aux or top in 7.3 is anything standing out as a hog that wasn't there in 7.2?
Is it slower to boot or run applications?

Mandrake's kernels are suppose to be optimized for Pentiums, so it may run faster for you.


5:45 am on Jun 20, 2002 (gmt 0)

10+ Year Member

No nothing running thats taking up the resources. The big thing is the lack of DMA if I do a hdparm on device hda it tells me I am pulling 3 megs a second a on Maxtor ultra 133.

Even X is slow and not clean and I have a Gforce 3 TI 500 card. I have a gig of ram and a 2.26 ghz P4 I shouldn't have to wait for any thing.I can wait two to three seconds for a terminal window.

Now with 7.2 installed it moves pretty good but not where it should be. I could set it up with 7.2 but there is alot of extra stuff to upgrade.

If I thought switching to Mandrake would solve the problem I would do it.

What I don't know is how much Redhat messes with the Kernel. Mandrake site says theirs comes from kernel.org


5:56 pm on Jun 24, 2002 (gmt 0)

10+ Year Member

I purchased the box version of Mandrake 8.2 the power pack addition. I have to say it is quite impressive. So in trying to get the best install with overall performance I have played with Redhat 7.2, 7.3 and Mandrake 8.2. Keeping in mind that I am working with a motherboard that has been available for less then a month P4B533-e [usa.asus.com]

1.) Simple install,the only problem I ran into was setting up my usb mouse. The board has three usb controlers and my Monitor has a hub also. I had to learn which driver to use and only install one. My first attempt I had installed two drivers before I found the one that turned the mouse on so at bootup I had a conflict.

2.) Cups with Gimp-print 4.2 is the default print dameon and it found my printer and had the correct driver. Installed it Perfect.

3.) My USB scanner was found and the Xsane config was taken care of with a icon place on my desktop.

4.) Three zip drives, internal paralel port and USB. All installed Perfect. With Mandrake these drives are set up so that the mount and unmount process is transparent very Windows like.

5.) Cdrom and dvd with Xine installed. Had to download and install dvdnav and Movies played correctly.

6.) The install found my Gforce 3 Ti500 card and it installed the Nvidia drivers. This was very cool not that manualy installing the nvidia drivers is that tough but it can be alittle tense. Any time you mess with X it can be stressfull.

7.) Installer picked the wrong driver for my onboard C-media 6 channel audio and ignored spdif

8.) Could not find my onboard lan card.

9.) Resorce collision with the ide controller so no dma.

10.) Drakex is a nice interface for setting up hardware, network, fonts (even a button to add Windows fonts), view log files and I am sure alot more. Because of the resource collision I could not use the drake-hardware browser the system would lock every time I clicked it. So I could not find another interface to fix the sound.

11.) One interesting thing I noticed is that the installer compiled alot of drivers for hardware not on my system making it very simple to add new hardware. It almost looks like you could change the board and it would boot up and make the changes.

12.) Even with out a IDE controller the machine was very responsive and felt good.

13.) The big minus besides the IDE deal was no KDE 3.

Redhat 7.3

1.) Install went smooth. Turned on the sound plus enabled spdif. Found the lan card and configured the network.

2.) Could not enable the Ide controler.

3.) Still had to install gimp-print to get the printer right and switch the default dameon to Cups.

4.) Did not enable the paralel port zip.

5.) System runs very slow. Red hat installed a different pci driver then Mandrake and I think thats what is making the system stuffy.

6.) Manualy set up the scanner Xsane configs.

7.) Manualy have to install Nvidia drivers

8.) KDE3 is included.

Redhat 7.2

1.) Smooth install. It found the sound and did not enable spdif. Did not find the lan card.

2.) Everything needs to be updated.

3.) It did install the ide controler and gave me UDMA 66.

4.) Best running machine.

All in all for first time users Mandrake is the most windows like and has paid more attention to the desktop user and external hardware.

I ordered another board this morning and hope to have it tomorrow. I am still not sure which distro to go with. Mandrake looks pretty good.

When major updates happen like KDE3 or Xfree86 does Mandrake soft include those as auto updates or do you have download and install all the dependant files ?


9:05 am on Jun 25, 2002 (gmt 0)

WebmasterWorld Senior Member littleman is a WebmasterWorld Top Contributor of All Time 10+ Year Member

That's a really interesting comparison David, you wouldn't want to try SuSE now would you? :)

It's been my experience that Mandrake does not automatically upgrade major packages like KDE. The thing that is getting to me about the rpm based system is how there seems to be a role over of dynamically linked libraries 6-8 months. I guess it isn't that big a deal if you aren't the type to download the latest of THIS or THAT, but I find myself going through dependency hell every couple of months. I am using Mandrake 8.1 right now, but a lot of the apps I am using are more resent than what is on 8.2 -- this gets to be a headache after a while.


8:14 am on Aug 14, 2002 (gmt 0)

10+ Year Member


I got the same problem as you do. I also have a P4B533-e motherboard and it gives probaly the same problems as you have.

I do have a question for you, without a ide-controller what is your transrate speed of your HD??? I experienced that if you transfer 650mb data from the cdrom to the HD that the system almost hang ?!?

b.t.w. how did you disable the dma?



2:57 pm on Aug 14, 2002 (gmt 0)

10+ Year Member

Hi Michael88

As of a week ago with the release of kernel 2.4.19 the problem has been taken care of. You need to patch kernel 2.4.19 with 2.4.19-ac4 and so far my system has been stable.

without the new Kernel ..

If you have Redhat 7.2 installed you can turn DMA on for your drives hdparm -d1 /dev/hda, however even when I turned it on on my dvd drive it did not perform well at all. Cdrom performance is probably the same kind of deal.

Redhat 7.3 with a default install has all kinds of problems with the drives. I could not work with it.

So the new kernel is the answer..

<< b.t.w. how did you disable the dma? >>

Dma was disabled by default. You can turn it on with RH 7.2 but not 7.3


11:59 pm on Aug 14, 2002 (gmt 0)

10+ Year Member

>Is Mandrake better and why ?
Mandrake 8.2 comes with the 2.18 kernel is there a chance that it would run better?

I think Madrake are very inconsistent, I used 8.0 and it was OK, but when I switched to 8.1 the problems began.

>The big thing is the lack of DMA if I do a hdparm on device hda it tells me I am pulling 3 megs a second a on Maxtor ultra 133.

Really strange, I was into 6-7MB/s on a 300MHz K6-2 with 256MB RAM and an old Quantum 3.2GB.

A little note:
When I switched from Mandrake 8.1 to NetBSD 1.5.2 the speed improvement was around 30-40%.

I am now using Slackware 8.1 and it's even faster, but not something for the Windows users.


6:00 am on Aug 15, 2002 (gmt 0)

10+ Year Member


Thanks for the tips. I will search on the internet for the release of kernel 2.4.19 patch with 2.4.19-ac4. Do you have any good tips, links or documentation about compiling the new kernel for me???

You know, I never do that before. Please help! I have Mandrake 8.2. kernel 2.4.18 running in my system with vitale applications.

Best regards,



7:10 am on Aug 15, 2002 (gmt 0)

10+ Year Member

I have not compiled a kernel on mandrake but here is how I have done it with Red Hat. It should be similar.

Before you get started make sure you have a WORKING boot disk. Just in case you lock your self out.

First go to [kernel.org...] and down load the kernel source and the ac patch.

It is recomended to use a directory other then /usr/src to compile your custom kernel. I have just used my home directory. The main thing is you want a directory that you have full permissions on.

Once you have the source and the patch in your directory then.


Type these commands

gunzip linux-2.4.19.tar.gz
tar xvf linux-2.4.19.tar
gunzip patch-2.4.19-ac4.gz

Then copy patch-2.4.19-ac4 into the newly created directory linux-2.4.19.

You are now ready to apply the patch.

cd linux-2.4.19

and then

patch -p1 < patch-2.4.19-ac4

You will see code fly by as it patches the source. You should not get any errors.

The next thing to do is to create the .config file. There are several ways to do it but I have been using the xconfig. It is a graphical interface with a series of menu options. Take your time and use the help buttons to help you make your decisions. Use Modules as much as possible it will keep the kernel size down

To get it started type

make xconfig

Once you have completed save and exit.

Next type ..

make dep

watch the code fly by

them type

make clean

then type

make bzImage // notice the capital I

This should end telling you the size of the bootable image with out errors. Mine is at 724kb

Now you need to compile the modules.


make modules

You should get no errors at the end but you more then likly will your first couple of trys.I went through a trial and error several times. Adjust the .config file and repeat steps to this point until you are error free. Google was a big help to me on some of the error messages I got.

next su down to root

and type

make modules_install

and then

make install

On a redhat system using grub as the boot loader you would be set to reboot.

When you reboot using the new kernel you could crash, keep track of the errors and boot back into your old kernel. Research the errors fix the .config file and redo the whole process.

If I remember right Mandrake used lilo as the default. I have not worked with it and don't know if you need to do additional stuff. Research this before you begin

This has worked well for me on REDHAT I don't know about Mandrake.

Maybe we have a Mandrake expert that could advise as to how I might be miss-directing ??


9:00 am on Aug 15, 2002 (gmt 0)

10+ Year Member

Thanks David for your tips!

Unfortunely I got already an error message from the beginning.

This is what I did:

I copy the patches in the created directory /home/linux-2.4.19. as you described and did the following command:

patch -p1 < patch-2.4.19-ac4

Which gives me the following error:

can`t find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:

¦diff -u --exclude-from /usr/src/exclude --new-file --recursive linux.vanilla/arch/alpha/config.in linux.19-ac4/arch/alpha/conf.im
¦--- linux.vanilla/arch/alpha/config.in 2002-08-03 16:08:19.000000000 +0100
¦+++ linux.19-ac4/arch/alpha/config.in 2002-07-29 13:58:35.000000000 +0100

What does that mean ?



3:26 pm on Aug 15, 2002 (gmt 0)

10+ Year Member

Did you get the patch and kernel source from kernel.org ?

There is only one patch, be sure you downloaded the full source code linux-2.4.19.tar.gz

Did put your self (using the cd command) in the directory linux-2.4.19 before you issued the patch command ?

In my case the directory structure looks like this


so I would

$ cd /home/myhome/linux-2.4.19
$ patch -p1 < patch-2.4.19-ac4

The error means the patch can't find the source.


9:38 am on Aug 22, 2002 (gmt 0)

10+ Year Member


I think, somehow I messed up my system and I don`t know what to do.
Booting up the new kernel, I gotthe follwowing errors:

modprobe:modprobe:can`t locate module char-major-29
modprobe:modprobe:can`t locate module char-major-10-135
Mounting local filesystems [failed]
Mounting other filesystems [failed]

After that I got the login menu. However I can`t logging as a "user" and the only choice that I have is to login as "root".

What do I did wrong during the compilation process and how do I solve this?


11:01 am on Aug 22, 2002 (gmt 0)

WebmasterWorld Senior Member littleman is a WebmasterWorld Top Contributor of All Time 10+ Year Member

Michael, do you have a boot disk? If so, use it to boot up your system, to get you up and running again.

Try to edit "/etc/modules.conf" and comment out the sections where char-major-29 and char-major-10-135 are listed and then try to reboot.
char-major-10-135 - is the hook to the bios clock
char-major-29 graphdev Not available yet?


2:35 pm on Aug 22, 2002 (gmt 0)

10+ Year Member

Your local filesystem problem is probably due to ext3 not being turned on as a module (it is not by default in the .config), you will need to add it and recompile.

char-major 29 - you need to add the module in your config for "enhanced realtime clock support"

Don't know what to turn on for char-major 10-135. If I can get some time today I will take alook.

Hey "You are almost There"


3:11 pm on Aug 22, 2002 (gmt 0)

10+ Year Member


Can you be more specific how I add "ext3 module" and "char-major 29" in my modules.config and recompile ??!
I am very exiting about it and can`t wait for your answer since "I am almost there"!

Many thanks for your help.


3:17 pm on Aug 22, 2002 (gmt 0)

10+ Year Member


Looking in my modules.conf file, I can see only 1 sentence:

probeall scsi_hostadapter ide-scsi

further notthing!?!?


3:21 pm on Aug 22, 2002 (gmt 0)

10+ Year Member

I am going to assume you used xconfig to create your config file. Under file systems look for ext3, The real time clock is under character devices.

I can't be sure from here that it is ext3 but I stumbled on that one.

The next time you get booted into the new kernel grab a terminal and type dmesg, It might help you determine the source of the problem.


12:28 pm on Aug 27, 2002 (gmt 0)

10+ Year Member


Thanks for your help! I am "there"! It took me days and nights but finally I am satisfy! Only issue that I have is the "char-major 29" that comes up...but I am happy :) Thanks again!



1:59 pm on Aug 27, 2002 (gmt 0)

10+ Year Member

Enjoy your board

I solved the char-major 29 with the real time clock support.


Featured Threads

Hot Threads This Week

Hot Threads This Month