Welcome to WebmasterWorld Guest from 34.204.203.142

Forum Moderators: bakedjake

Message Too Old, No Replies

POP3 not working after migrating to new server

     
10:47 pm on Apr 22, 2005 (gmt 0)

Full Member

10+ Year Member

joined:Aug 29, 2003
posts:236
votes: 0


A while back my hosting company had to migrate my server to a new dedicated server because of a misconfiguration. They moved everything to the new server by doing an "rsync".

Ever since this move noone can get mail using POP3 (can't log in - using outlook, outlook Express, etc.). However, the accounts are still there and working because I can use IMAP to verify it.

After the move there was a little issue with IMAP and someone on this board helped me find out that a symlink was missing - so I recreated that symlink and IMAP worked flawlessly - I'm wondering if perhaps a symlink is missing for pop3 as well.

If I remember correctly, when my hosting company moved my files using rsync - all files got moved but it did not recreate the symlinks.

(Linux ES - with Qmail) - Cannot loggin with POP3. I've even tried telneting in from command line (port 110) - but it says: Password supplied for "username" is incorrect. Yet, loging in with IMAP is fine.

Any thoughts?

11:44 pm on Apr 22, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Apr 20, 2004
posts:1477
votes: 0


If only they had used:
rsync -a
!

The "a" option would have transferred the files in "archive" mode, preserving the symlinks, devices, attributes, permissions, ownerships, etc. (and, of course, the "hard" links)

Anyhoo ...

When you telnet in, depending on your Linux distro, you'll be looking for the pop3 daemon's launchpad, which is either initd or xinetd, most likely.

For example, on Red Hat 7.x, you'll find the

/etc/xinetd.d/ipop3d
file. On Fedora Core 1, you'll find the
/etc/rc.d/init.d/ipop3d
file. Open it for editing and look for the line within the curly braces that begins "
disabled =
".

It's a good bet that its value is "

yes
". Change the value to "
no
", save the file and exit your editor. Then restart the initd or xinetd daemon using
service xinetd reload
or
service init reload
.

On many distros (including some configurations of the above two), you have the option of using xinetd as the daemon's service, so do a "

locate pop3
to find out what options you have, and which daemon you want to run and what service you want to run it under.

Are we on the right track?

7:42 pm on Apr 25, 2005 (gmt 0)

Full Member

10+ Year Member

joined:Aug 29, 2003
posts:236
votes: 0


Whew - I found the problem. It was due to Qpopper running on the new RH machine. It was starting before qmails pop3 program could run.