Welcome to WebmasterWorld Guest from

Message Too Old, No Replies

Site not getting spidered.

Any ideas why?


traffik daddy

2:02 pm on Jun 12, 2006 (gmt 0)

10+ Year Member

I have created my website using a very popular open source shopping cart, the sites design is very nice, in total there are over 10,000 pages with more to add. As I come to finish the site it may well have over 100,000 pages.

I have been submitting my website to numerous free directories that pass over good PR, got some quality backlinks from related websites, practiced only plausable SEO techniques and stuck within the guidelines set by any white hat SEO.

My website has now been online for well over 12 months, maybe longer, only recently, say within the last 5-6 months I have set this cart up in PHP and MySQL.

Now, I set the cart up in a different directory, so I redirected the old index page to my new one using the redirect command in CPanel. Everything was fine, it worked very well. The PR of my old page was passed along to my new one, which was even better because I was weary as my site has a PR5 homepage.

The site is set up very well, the meta tags, title tags, etc are all intact and the functionality of the cart runs very smooth.

Then something happened, about 2 months ago Google stopped listing my site in their index. Currently I have 3 pages showing and one of those is omitted, so its showing the new homepage and one product page that is 2 link clicks into the site.

I dont use a robots.txt file although I'm thinking of adding one very soon and I dont use Google sitemaps. I stopped work on the website and concentrated on other projects in hope that Google will come back to my site and index all of the pages, but it hasn't and I can't understand why.

Now I'm have tried a plugin that makes the URL's so-called SEO friendly. Rather than having the php string it makes the URL look like a directory URL. So now rather than www.mysite.com/subfolder/index.php?main_page=index&cPath=65_146 I get www.mysite.com/subfolder/index.php/main_page/index/cPath/65_146

Will this work? I had no supplemental results prior to the removal from the Google index either so I have no clue what it is that I have done wrong.

Can anyone spare some advice please who has been in this situation before? Any steps I can take to get my site listed again?

Thank you in advance :)



Featured Threads

Hot Threads This Week

Hot Threads This Month