Welcome to WebmasterWorld Guest from 54.167.157.247

Message Too Old, No Replies

Key words and domain names

Trying to understand why kw search doesn't show site

   
12:34 am on Mar 16, 2005 (gmt 0)

10+ Year Member



I know in various threads this matter has been discussed, and I've read many, but I'm still a little confused.

I have a site that has a url such as name1name2-name3.tld

I currently get a 1 ranking on Google when searching on "name1name2" and anywhere from 11-30 on "name1 name2 name3".

On the combination of "name1 name2" - my preferred search combination - my site doesn't appear at all. (It does on MSN)

* The title on the index page is written as "name1 name2" - "name1name2-name3.tld"

* I use "name1 name2" in the meta headings, in the h1 and/or h2 headings.

* I use the "name1 name2" combination in the text on relevant text pages where possible.

* Pages are linked between each other, and there are some off-site links to the site.

When I search Google on "name1name2" it finds the index page, but highlights the "name1name2" part of the url in the title, not the "name1 name2" preceding it. Yet searching on "name1 name2" doesn't find the site at all.

I just don't know what else to do to get "name1 name2" to provide a good response in Google. The site has been active since about last July, and per above, I get rank 1 on "name1name2", so I know google is finding us.

Can anyone advise, please? All help would be gratefully received.

apt83

[edited by: ciml at 3:52 pm (utc) on Mar. 16, 2005]
[edit reason] Examplified [/edit]