Welcome to WebmasterWorld Guest from

Forum Moderators: buckworks

Message Too Old, No Replies

osCommerce - blank page

catalog/index.php completely blank - why?

9:31 pm on Dec 3, 2005 (gmt 0)

New User

10+ Year Member

joined:Apr 10, 2004
votes: 0

Hello, I posted this question to the osCommerce forums but, so far, no response. Perhaps someone here can help?

I uploaded osCommerce to the site I'm working on, created a database, and 'successfully' installed osCommerce. However, when I visit www.mysitename.com/catalog/, my index.php page in the catalog folder is completely blank. When I right click to see the source code it reads: <html><body></body></html> only.

I checked to make sure everything uploaded correctly, have recreated my database and reinstalled three times but always with the same result. My searches have come up with people encountering the same problem but none of their solutions have worked for me.

I also tried uploading Zen Cart with the same result. Their FAQ's make mention of this problem and have a few suggestions such as adding your port number in the configure.php file (which is 21, I think...) but I tried and have had no luck.

I don't know if this has anything to do with anything but the host (Yahoo!) won't allow the .htaccess file to be uploaded. Instead, I altered the permissions for the catalog/admin in the webhost's file manager. Other than any .htaccess files and the zip file, I think I have all the files uploaded.

Here is the configure.php code (this was the code that was generated during the install without any changes other than code specific to the site I'm working on generalized and link to osCommerce removed):

osCommerce, Open Source E-Commerce Solutions

Copyright (c) 2003 osCommerce

Released under the GNU General Public License

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://my-site.com'); // eg, [localhost...] - should not be empty for productive servers
define('HTTPS_SERVER', 'https://my-site.com'); // eg, [localhost...] - should not be empty for productive servers
define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'my-site.com');
define('HTTPS_COOKIE_DOMAIN', 'my-site.com');
define('HTTP_COOKIE_PATH', '/catalog/');
define('HTTPS_COOKIE_PATH', '/catalog/');
define('DIR_WS_HTTP_CATALOG', '/catalog/');
define('DIR_WS_HTTPS_CATALOG', '/catalog/');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
define('DIR_FS_CATALOG', '/catalog/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

// define our database connection
define('DB_SERVER', 'mysql'); // eg, localhost - should not be empty for productive servers
define('DB_SERVER_USERNAME', 'myusername');
define('DB_SERVER_PASSWORD', 'mypassword');
define('DB_DATABASE', 'oscommerce');
define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

Any clue what I have done wrong along the way and how to fix it? Thanks so much! :o)

3:14 am on Dec 4, 2005 (gmt 0)

New User

10+ Year Member

joined:Nov 15, 2005
votes: 0

Well, like they always ask with anything to do with electricy "Is is plugged in?".

This is the same type of question: Does your host support PHP?

Also, you created the SQL database (running the SQL commands to create the tables)

I've got OSC 4 stores running, and have never seen this problem. The problem may be with the host (Yahoo).

2:09 pm on Dec 4, 2005 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member lorax is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Mar 31, 2002
votes: 0

2 things come to mind.

1) did you change permissions on the files as per instructions? (777, 755 and the like)

2) did you upload the files in the proper formats as per instructions? (ASCII or Binary)

[edited by: lorax at 6:09 pm (utc) on Dec. 4, 2005]

3:45 pm on Dec 4, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Nov 1, 2002
votes: 0

Did you use the OSC file manager to make changes? I have had problems when doing this, for reasons that I never understood. In other words, I would getr a successful install, and then use the built in file manager (from the admin section) to change the text on the front page, and everything then vanished!

I now make changes on my local system and FTP them to the server.


5:03 pm on Dec 5, 2005 (gmt 0)

New User

10+ Year Member

joined:Apr 10, 2004
votes: 0

Hi everyone, thanks so much for the suggestions. :o)

My webhost does have everything necessary for osCommerce, I changed the permissions and I uploaded everything in ASCII. I never used the OSC file manager to make changes as my webpage didn't have any content to change! ;o)

Good news - I got it to work yesterday! I completely deleted everything and started from scratch - for the third time! I went through my upload with a fine tooth comb, ensuring everything was there. I did this before but perhaps I wasn't thorough enough?

Then, I went through the install process again, this time not enabling the ssl. Yahoo is not very clear on this... they say that all plans come with it but, deeper into their info section, it also say that only the two most expensive plans have it, so who knows?

At any rate, it works, it works! I have the default store up and so far so good. I downloaded the whole working store to my pc just in case I mess something up when I start to customize it. Fingers crossed!

Thanks again, everyone! :o) Crissy.