Welcome to WebmasterWorld Guest from 54.158.175.78

Forum Moderators: open

Message Too Old, No Replies

Opera vulnerability

All versions prior to 7.50

   
11:30 pm on May 25, 2004 (gmt 0)

WebmasterWorld Senior Member encyclo is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Well, it makes a change from bugs in IE! This is for those numerous Opera fans who hang around in this forum.

Full advisory [idefense.com]

Basically, Opera doesn't handle telnet connections properly, creating a situation where anyone can write arbitrary information to your hard disk, overwrite files, etc. It's not a huge bug, but the advice is to upgrade to 7.50 and/or disable telnet handling in Opera (who uses Opera for telnet anyway?!)

Apparently there's a potential exploit for Firefox and other Mozilla variants via their handling of ssh too, so no comments about switching to them please! There is currently no fix for this problem.

8:17 am on May 26, 2004 (gmt 0)

WebmasterWorld Senior Member blobfisk is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Great catch - thanks encyclo!
12:14 pm on May 26, 2004 (gmt 0)

WebmasterWorld Senior Member leosghost is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



Nothing is secure ..to the curious mind ~: )