Welcome to WebmasterWorld Guest from 34.238.192.150

Forum Moderators: open

Message Too Old, No Replies

ugh. can't increase max_allowed_packet!?

I've tried everything....

     
1:07 pm on Feb 9, 2006 (gmt 0)

Preferred Member

10+ Year Member

joined:Nov 2, 2001
posts:597
votes: 0


can some one please explain to me exactly what I need to do to increase max_allowed_packet so that I can import my data?

I've tried about 20 different shell commands, and edited max_allowed_packet in the cnf files, but nothing seems to work, what am I missing here?

I'm a total noob with this stuff so keep that in mind if you reply :)

Thanks!

ADDED: Redhat/MSQL 4.1

3:20 pm on Feb 9, 2006 (gmt 0)

Administrator

WebmasterWorld Administrator coopster is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 31, 2003
posts:12555
votes: 3


If you set it in the cnf you will likely need to restart the server. Optionally, that is a dynamic variable and can be SET GLOBAL or SET SESSION from the command line as well.
4:06 pm on Feb 9, 2006 (gmt 0)

Preferred Member

10+ Year Member

joined:Nov 2, 2001
posts:597
votes: 0


I've restarted the server a couple times already with no luck.

I think the main problem is that I don't know the proper commands to run from shell. I've followed a variety of options from the mysql manual, but I must be doing something wrong.

Do you know what the proper commands are?

Thanks for trying to help!

1:47 pm on Feb 12, 2006 (gmt 0)

New User

10+ Year Member

joined:Feb 12, 2006
posts:2
votes: 0


You should edit the .ini or .cnf (depends on the setup you have) file that is read by mySQL.

Add in the line
max_allowed_packet=1MB

under the value of
[mysqld]

save the file

shut down the mySQL server

then start the mySQL server

login to mysql and type

mysql> show variables like 'max_allowed_packet';

you should get something like:

+--------------------+---------+
¦ Variable_name ¦ Value ¦
+--------------------+---------+
¦ max_allowed_packet ¦ 1048576 ¦
+--------------------+---------+
1 row in set (0.00 sec)

Does this work?