Welcome to WebmasterWorld Guest from

Forum Moderators: bill

Message Too Old, No Replies

USB keyboard and mouse not working in Win 98SE setup



12:10 am on Jun 19, 2006 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

I have a newer Dell machine (XPS 400 w/ SATA) running XP, which I'm trying to also install 98SE on. When I get into setup, the mouse is jumpy, but it works well enough. But then as soon as I hit a key, both the keyboard and mouse stop working properly. Long delays before keystrokes take effect, and not always the correct keystrokes. I have the same problem if I try to run Quake 1 outside Windows. It's an MS Digital Media Pro keyboard, and MS Laser Mouse 6000. Any ideas?



12:22 am on Jun 19, 2006 (gmt 0)

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

I don't see Windows 98 listed as a supported OS for your keyboard:

Digital Media Pro keyboard [microsoft.com]
System Requirements
One of the following:
Windows XP Professional, Home Edition, Media Center Edition, or Tablet PC Edition with a Pentium 233 MHz or higher processor
Windows 2000 Professional or Server with a Pentium 233 MHz or higher processor

Or for the mouse:

Laser Mouse 6000 [microsoft.com]
System Requirements
Windows XP Home or Professional Edition with Service Pack 2 or later with a Pentium 233 MHz or higher processor and 128 MB of RAM

Instead of dual booting you might want to look into running Windows 98 in a virtual PC.


1:12 am on Jun 19, 2006 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

True, but I asked because if the BIOS supports the keyboard, I don't see any logical reason for the OS not to. I might try a PS2 keyboard and mouse. My reason for wanting 98 is that I think it might run DOS games better than DOS itself on this machine.


4:54 am on Jul 5, 2006 (gmt 0)

10+ Year Member

I also had same problem with USB mouse and solved after using PS2 Connector with Win98SE.


9:47 pm on Jul 5, 2006 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member

My machine doesn't have PS/2 ports. USB Only. Argh.


8:37 am on Jul 7, 2006 (gmt 0)

10+ Year Member


I have 98SE and will give you some tricks to get USB problem solved. (as you have no PS2 Port with your system)

1) Upgrade your MOBO BIOS from Mfg. Site. In my case I upgrade it from Intel site.

2) Search for USB problem shooter with MOBO Mfg. site (it is there with Intel site)

3) In BIOS setting Disable Plug & Play Option

Finish, now your USB Mouse or KB should work OK.

A) If still problem is there, than In Bios you have 2 option for USB configuration. Just Enable only one NAME High Speed USB and disable other one. save setting and run System.

Still have problem

B) than just DISABLE both options for USB in BIOS.

Please use above setting one by one (except first 3 steps I mentioned at the top for upgrade and download).
If possible Note down the ORIGINAL SETTING of your BIOS before making any changes, it will useful for you if any other component starts giving problem after all new changes (possibilities is 0% for problem)


Featured Threads

Hot Threads This Week

Hot Threads This Month